Wahoo Elemnt

Paul B
Posts: 809
Joined: Mon Jul 09, 2012 10:51 pm
Location: Hobart

Wahoo Elemnt

Postby Paul B » Tue May 30, 2017 2:23 pm

So who is using one?? I have just picked one up after using Garmin units since 2013. First a 500 and most recently the excellent 520. But... since I just bought another bike I was in the mood for a change and thought that the Wahoo looked pretty decent.
Picked it up yesterday and while I am yet to ride with it, I spent some time setting it up and familiarising myself with the various functions.
First impressions are that it's pretty good. Well... really good. The configuration of the various fields are done on your phone, or even better, iPad. It's super easy to customise each page simply by dragging & dropping each field into the desired position. As you do it, the Elemnt display is instantly adjusted to show the updated layout. Pairing with a device is accomplished by pointing the camera at a pattern on the display of the unit.. Easy as. Adding bike sensors is fast as well.
Strava live KOMs look to be more functional now also with the ability to overlap segments, plus it doesn't take over the entire screen during the process. The size of the unit is perfect. Bigger than the Garmin 520 but a bit smaller than the 800 series. Though B&W only, the display is super crisp.
At this point, I would say it is highly unlikely I would go back to a Garmin unit. They have been good but annoyingly buggy. Apparently the support for the Elemnt is first class also. Winner 8)
Image

User avatar
biker jk
Posts: 6216
Joined: Tue Nov 17, 2009 6:18 pm
Location: Sydney

Re: Wahoo Elemnt

Postby biker jk » Tue May 30, 2017 4:06 pm

I've had mine for over six months and overall I'm pretty happy with it and feel I made the right decision to switch from Garmin. I much prefer the navigation on the Elemnt and the screen is super sharp even in bight sunlight. There are some bugs, however, which I believe might be fixed in a mid-June update. First, there's no option to calculate average cadence by excluding zeros, Second, normalised power is overstated (although perhaps this isn't the case with all power meters).

Harrys767
Posts: 47
Joined: Wed Jan 13, 2016 7:55 am

Re: Wahoo Elemnt

Postby Harrys767 » Wed May 31, 2017 2:40 pm

I've got an Elemnt Bolt. I love it! It does everything I need and more. They are a little less mature than the Garmin line of products and as such are a lot more receptive to customer feedback/feature requests.

There are a couple of things I would like to see improved (ability to set a known start elevation being one of them), but overall it's a great unit with massive battery life.

Paul B
Posts: 809
Joined: Mon Jul 09, 2012 10:51 pm
Location: Hobart

Re: Wahoo Elemnt

Postby Paul B » Wed May 31, 2017 7:27 pm

First ride with the Elemnt today. It's fantastic. Definitely a Garmin killer.
Image

Arbuckle23
Posts: 544
Joined: Sun Jan 11, 2015 7:07 pm
Location: Mornington Peninsula

Re: Wahoo Elemnt

Postby Arbuckle23 » Sun Jun 10, 2018 5:59 pm

May as well drag this up instead of starting a new thread.
And seeing that we haven't got the tech forum happening, to put a new thread in, yet :D :P

My Element Bolt decided to lock up on me when I started it this morning.
Stressed me a bit because I was about to race and wanted to ride to power :x Nearly had to race with the phone in the back pocket as no Strava upload means it would not have happened :D
Figured there had to be a hard reset option there somewhere and pushed various button combinations and it eventually restarted with no more problems. Research when I got home told me that you hold the power buttons for 10 seconds for a hard reboot.

Hope that is it for any issues and performed with fault up to today!
Just thinking as I type, installed an update a couple of days back. I wonder [insert deep thought smiley here] :?:

Paul B
Posts: 809
Joined: Mon Jul 09, 2012 10:51 pm
Location: Hobart

Re: Wahoo Elemnt

Postby Paul B » Tue Jun 12, 2018 10:56 pm

Arbuckle23 wrote:
My Element Bolt decided to lock up on me when I started it this morning.
Stressed me a bit because I was about to race and wanted to ride to power


Yea just a random computer glitch. They happen. Mine hasn’t missed a beat. Unlike the couple of Garmin units I owned which while very good, were nowhere near as reliable as the ELEMNT.
Image

User avatar
MichaelB
Posts: 9267
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Wahoo Elemnt

Postby MichaelB » Wed Jun 13, 2018 8:51 am

I have the Bolt and love it as well.

Just finished setting up a Garmin 520+ for a BNA review, and I'd forgotton how much of a faff it is to set up the data screens using push buttons !!!

There are still some good things about it, but ....

User avatar
tomee
Posts: 274
Joined: Wed Oct 15, 2014 4:30 pm
Location: Vic

Re: Wahoo Elemnt

Postby tomee » Wed Jun 13, 2018 9:45 am

switched about a year ago. love it except the only thing that has stopped working is auto uploading my ride once it hits a wifi connection.
So i have to launch the wahoo app and make it connect with the device to upload the ride

Shred11
Posts: 96
Joined: Sun May 18, 2014 12:32 pm
Location: Launceston

Re: Wahoo Elemnt

Postby Shred11 » Wed Jun 13, 2018 1:40 pm

Does the Elemnt have multiple trip meters? In other words: can it record (say) a lifetime odometer for the bike + the current trip distance + a second distance - e.g. for a multi-day journey?

One of the many irritations with my Garmin Edge 510 is that it only records the odometer, plus the distance for the current trip. The Garmin units seem to be optimised for racing and training, while I'm using my bikes for commuting and for occasional day trips that may involve multiple legs.

I very nearly ditched the Edge 510 late last year, when it frequently shut down during rides (losing all trip data each time) or appeared to function perfectly, but only recorded the final 200m of the ride. The Garmin forums have many posts from other users complaining about exactly the same bugs, but Garmin's firmware updates just shovel more (potentially bug-ridden) features in, without addressing these long standing problems. By trial and error, I found that leaving Bluetooth turned off during a ride was a work-around for the bugs, but then I have to faff around turning bluetooth back on to upload the ride when I get home. It's tolerable, but an irritation that I could do without and I'm keeping an eye open for a suitable replacement. The Lezyne Super GPS looks good, but I feel it may be a bit 'green'... and I'm "over" buggy bike computers.

User avatar
RonK
Posts: 10352
Joined: Mon Aug 24, 2009 2:08 pm
Location: If you need to know, ask me
Contact:

Re: Wahoo Elemnt

Postby RonK » Wed Jun 13, 2018 1:46 pm

Shred11 wrote:Does the Elemnt have multiple trip meters?

No.
Cycle touring blog and tour journals: whispering wheels...

Jasonr002
Posts: 3
Joined: Thu Jun 14, 2018 8:16 am

Re: Wahoo Elemnt

Postby Jasonr002 » Thu Jun 14, 2018 8:50 am

It appears that the Cycliq Fly 12 CE is somehow interfering with the 1.5 GHZ frequency that the GPS signal uses from the Wahoo Bolt. This makes the Wahoo Bolt unusable when used with the Fly 12CE. Does anyone have an answer?

User avatar
RonK
Posts: 10352
Joined: Mon Aug 24, 2009 2:08 pm
Location: If you need to know, ask me
Contact:

Re: Wahoo Elemnt

Postby RonK » Thu Jun 14, 2018 9:05 am

Jasonr002 wrote:It appears that the Cycliq Fly 12 CE is somehow interfering with the 1.5 GHZ frequency that the GPS signal uses from the Wahoo Bolt. This makes the Wahoo Bolt unusable when used with the Fly 12CE. Does anyone have an answer?

It's a common compliant that many lights interfere with cycle computers (and not just the Elemnt). I've heard wrapping the light in foil will shield it.
Cycle touring blog and tour journals: whispering wheels...

User avatar
biker jk
Posts: 6216
Joined: Tue Nov 17, 2009 6:18 pm
Location: Sydney

Re: Wahoo Elemnt

Postby biker jk » Thu Jun 14, 2018 9:47 am

Jasonr002 wrote:It appears that the Cycliq Fly 12 CE is somehow interfering with the 1.5 GHZ frequency that the GPS signal uses from the Wahoo Bolt. This makes the Wahoo Bolt unusable when used with the Fly 12CE. Does anyone have an answer?


Does the Bolt use a different GPS frequency than the Elemnt? I ran a Fly 12 (previous model) and Wahoo Elemnt without any problem.

User avatar
RonK
Posts: 10352
Joined: Mon Aug 24, 2009 2:08 pm
Location: If you need to know, ask me
Contact:

Re: Wahoo Elemnt

Postby RonK » Thu Jun 14, 2018 10:16 am

RonK wrote:
Jasonr002 wrote:It appears that the Cycliq Fly 12 CE is somehow interfering with the 1.5 GHZ frequency that the GPS signal uses from the Wahoo Bolt. This makes the Wahoo Bolt unusable when used with the Fly 12CE. Does anyone have an answer?

It's a common compliant that many lights interfere with cycle computers (and not just the Elemnt). I've heard wrapping the light in foil will shield it.

Found the previous thread about this and it was the camera causing the interference. OP doesn't say if the issue was solved.
I suppose it is possible that the smaller Elemnt Bolt has less internal shielding than the original Elemnt.

Wahoo Elemnt Bolt - GPS dropout at Akuna
Cycle touring blog and tour journals: whispering wheels...

dampier
Posts: 119
Joined: Sat Jan 16, 2010 12:35 am

Re: Wahoo Elemnt

Postby dampier » Thu Jun 14, 2018 3:25 pm

Hi,

Does the Wahoo support the Di2 D-Fly? I am looking at a new computer and have come to rely on the gear displays particularly when I am in traffic.

Thanks

User avatar
RonK
Posts: 10352
Joined: Mon Aug 24, 2009 2:08 pm
Location: If you need to know, ask me
Contact:

Re: Wahoo Elemnt

Postby RonK » Thu Jun 14, 2018 3:55 pm

dampier wrote:Hi,

Does the Wahoo support the Di2 D-Fly? I am looking at a new computer and have come to rely on the gear displays particularly when I am in traffic.

Thanks

It's all on the product page. https://au.wahoofitness.com/devices/bik ... ter-elemnt
Cycle touring blog and tour journals: whispering wheels...

dampier
Posts: 119
Joined: Sat Jan 16, 2010 12:35 am

Re: Wahoo Elemnt

Postby dampier » Fri Jun 15, 2018 3:02 pm

Thanks right down the bottom

Who is online

Users browsing this forum: 10speedsemiracer, Bah77, chriso_29er