Garmin 520 Issue

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Thu Oct 26, 2017 9:03 am

I've had no issue with the notifications on the 520. To me, this is one of the key features that made me upgrade from the 500 to the 520.

Had confirmation from mate he's still using the Edge 25 as a spin class cadence display. Bugger.

Arbuckle23
Posts: 295
Joined: Sun Jan 11, 2015 7:07 pm
Location: Mornington Peninsula

Re: Garmin 520 Issue

Postby Arbuckle23 » Thu Oct 26, 2017 1:24 pm

Well have a ticket number.
Sent proof of purchase and photos to show no damage to the 520. See if they offer me anything worthwhile.
And paying for a refurb will not be on my list. Rather move to the opposition than do that, even if it costs me more.

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Thu Oct 26, 2017 4:30 pm

How old is your Arbuckle23 ?

May try the same on mine. It's well out of warranty, but maybe worth a try. Let us know how you get on, please

Arbuckle23
Posts: 295
Joined: Sun Jan 11, 2015 7:07 pm
Location: Mornington Peninsula

Re: Garmin 520 Issue

Postby Arbuckle23 » Thu Oct 26, 2017 6:27 pm

Was 12 months old at the beginning of the month, so only just over the standard warranty period.
Will update as we go.

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Mon Oct 30, 2017 10:04 am

Mine was purchased when they were released, so just over 2 years now.

Looking seriously at the Bolt, but o/seas suppliers can't ship to Oz and no one seems to discount locally, so it seems to be stuck at $399. Grrrrr

Arbuckle23
Posts: 295
Joined: Sun Jan 11, 2015 7:07 pm
Location: Mornington Peninsula

Re: Garmin 520 Issue

Postby Arbuckle23 » Mon Oct 30, 2017 10:46 am

Pushys have codes at the moment $45 off.
Thinking I might pull the trigger and if Garmin come to the party, sell any replacement or repaired 520 off.

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Mon Oct 30, 2017 11:40 am

Damn. That makes it very tempting .....

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Mon Nov 06, 2017 12:57 pm

Arbuckle23 wrote:Was 12 months old at the beginning of the month, so only just over the standard warranty period.
Will update as we go.


Any update ?

Arbuckle23
Posts: 295
Joined: Sun Jan 11, 2015 7:07 pm
Location: Mornington Peninsula

Re: Garmin 520 Issue

Postby Arbuckle23 » Mon Nov 06, 2017 1:07 pm

Communication with Garmin is, shall we say "interesting".
Just got an email asking for me to call them again.

In the meantime I bought a Wahoo Elemnt Bolt.
If they do something, like a warranty replacement or repair, I will sell the 520 and keep the Bolt.
I used funds I was saving for something else to fund the Bolt.

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Mon Nov 06, 2017 6:50 pm

Well, mine died tonight, so decision time

Bolt or 520 refurbished .....

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Tue Nov 07, 2017 1:15 pm

well, I tried to open up the 520 (per some dodgy instructions online) to see if I could resolder the connector myself, but gave up.

Briefly contemplated on getting the refurbed 520 from Garmin Aus and then keeping an eye out for a bargain Bolt. Made a couple of calls, and one place offered a $50 discount without much prompting and had it in stock. Organising a mate to pick it up this arvo when he does his spin class with them. :D

Anyone want a 520 that is basically fine, has some soldering skills for bugger all ?

Arbuckle23
Posts: 295
Joined: Sun Jan 11, 2015 7:07 pm
Location: Mornington Peninsula

Re: Garmin 520 Issue

Postby Arbuckle23 » Tue Nov 07, 2017 5:35 pm

I think you will enjoy the Bolt. I am happy with mine.

My 520 is being posted off to Garmin tomorrow, we shall see what they do.

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Tue Nov 07, 2017 8:45 pm

I’m sure I will. The reading that I have done about them is overwhelmingly positive, especially when compared to Garmin.

Hopefully I’ll be as happy as you !

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Wed Nov 08, 2017 8:07 pm

Well, I picked the Bolt up this arvo.

The setup via the app is so ridiculously easy compared to the Garmin faffing about, and I LOVE the zoom function for the screen metrics.
Something I hadn’t had available, but is a brilliant idea.

Only downside I can see so far is lack in f colour, but I think I’ll live.
1st trial ride tomorrow, so fingers crossed !!

Arbuckle23
Posts: 295
Joined: Sun Jan 11, 2015 7:07 pm
Location: Mornington Peninsula

Re: Garmin 520 Issue

Postby Arbuckle23 » Thu Nov 16, 2017 10:42 am

Well, good news.

Just got advice from Garmin that they are sending me a new 520. Great service from them.
Leaves me with an new 520 to sell now, I will keep the Bolt as I quite like it.

User avatar
Comedian
Posts: 5278
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Re: Garmin 520 Issue

Postby Comedian » Thu Nov 16, 2017 1:15 pm

I don't know if this is the same problem (probably not), but one of the "weird things" about my Garmin 810 is some days when you plug it in to charge it just turns on. You can keep plugging it in and un plugging it as much as you like but it won't charge.

The only way to get it to charge is to force it to mount as a drive by holding the left button as it starts...

User avatar
ValleyForge
Posts: 1489
Joined: Tue Jan 27, 2009 5:37 pm
Location: Brisbane

Re: Garmin 520 Issue

Postby ValleyForge » Thu Nov 16, 2017 9:06 pm

Comedian wrote:I don't know if this is the same problem (probably not), but one of the "weird things" about my Garmin 810 is some days when you plug it in to charge it just turns on. You can keep plugging it in and un plugging it as much as you like but it won't charge.

The only way to get it to charge is to force it to mount as a drive by holding the left button as it starts...

Is it charger or cable specific?
Ha ha ha! Cookies on dowels.

User avatar
MichaelB
Posts: 8206
Joined: Tue Feb 20, 2007 9:29 am
Location: Adelaide, South Australia

Re: Garmin 520 Issue

Postby MichaelB » Fri Nov 17, 2017 7:54 am

Sounds very much like the USB mount to PCB joints just like on mine.
I looked at doing a SM USB mount repair on another project and it’s just too tiny so beyond me

Arbuckle23
Posts: 295
Joined: Sun Jan 11, 2015 7:07 pm
Location: Mornington Peninsula

Re: Garmin 520 Issue

Postby Arbuckle23 » Fri Nov 17, 2017 7:58 am

Sounds like the failure on mine as well. If I jiggled the lead and sat it on an angle to "load" the connection it would connect, but don't breath near it.

User avatar
Comedian
Posts: 5278
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Re: Garmin 520 Issue

Postby Comedian » Fri Nov 17, 2017 8:28 am

ValleyForge wrote:
Comedian wrote:I don't know if this is the same problem (probably not), but one of the "weird things" about my Garmin 810 is some days when you plug it in to charge it just turns on. You can keep plugging it in and un plugging it as much as you like but it won't charge.

The only way to get it to charge is to force it to mount as a drive by holding the left button as it starts...

Is it charger or cable specific?

It seems to be random.. but it happens more at work than at home. I just have to hold the left button down and that sorts it though. :shock:

Arbuckle23
Posts: 295
Joined: Sun Jan 11, 2015 7:07 pm
Location: Mornington Peninsula

Re: Garmin 520 Issue

Postby Arbuckle23 » Fri Nov 17, 2017 3:13 pm

A refurbed 520 turned up today :)

Can't knock Garmin for that, a few weeks out of warranty and purchased overseas, kudos to them. Excellent service.

I found the email communication was a bit poor, the best way to contact them was to ring their Oz contact number.
Call centre seems to be in Australia, or their accents are very good

Have sold it already to a friend of a friend. 520 was nice, but the Bolt is just a little ahead.

Who is online

Users browsing this forum: Alex Simmons/RST, lard, Lukeyboy, mikesbytes