Schwalbe Ultremo blowing off rim

Workshop tales, trials and disasters.
Maintenance tips, techniques and myths.
Technical discussion, description and outright lies

Re: Schwalbe Ultremo blowing off rim

Postby Comedian » Wed Dec 05, 2012 5:27 am

jacks1071 wrote:Comedian are you familiar with the definition of insanity?

Sounds like you've gone to lengths to work out whats causing the issue. I highly recommend you change to some different tyres although I've never had the issue you describe.

I did have some Ultremo casings fail a while ago, about 6 tyres actually. They were replaced under warranty and I never had another issue. If you've ever seen a snake thats eaten a rat or a cat thats what the tyre looked like - big bulges in it.

If you want a really tight tyre, get some tubeless tyres from Hutchinson and run them with tubes. They are TIGHT, the bead on them doesn't stretch.


I have... I've just striped the brand new ultremos and put some conti force and Attacks on. :)
Once you can climb hills on a bike it's all downhill. :mrgreen:

Hopefully I'll know what that's like..... one day. :shock: :lol:

Image
User avatar
Comedian
 
Posts: 4392
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

by BNA » Wed Dec 05, 2012 9:56 am

BNA
 

Re: Schwalbe Ultremo blowing off rim

Postby biker jk » Wed Dec 05, 2012 9:56 am

I know of a rider that was getting constant "punctures" recently and went through many, many tubes and quite a few tyres. The cause was the rear brake pads rubbing the tyres. You just never know.
User avatar
biker jk
 
Posts: 2181
Joined: Tue Nov 17, 2009 5:18 pm
Location: Sydney

Re: Schwalbe Ultremo blowing off rim

Postby usernameforme » Wed Dec 05, 2012 11:56 am

Comedian wrote:Looks like I might not be so alone...
http://weightweenies.starbike.com/forum/viewtopic.php?f=3&t=96779

If you read further here, it suggests that a bad craftsman always blames his tools... If they blow off after you mount them, I'm almost certain that the tires were incorrectly mounted. These are one of the few tyres that are (supposedly) safe on a Stans ZTR 340 (which is notorious for having clincher set-ups blow off)
Can you imagine what I would do if I could do all I can? - Sun Tzu
___________________________
Giant Defy Advanced 0
Shogun Katana
usernameforme
 
Posts: 764
Joined: Thu Jul 14, 2011 7:01 pm
Location: Adelaide

Re: Schwalbe Ultremo blowing off rim

Postby Comedian » Wed Dec 05, 2012 12:12 pm

usernameforme wrote:
Comedian wrote:Looks like I might not be so alone...
http://weightweenies.starbike.com/forum/viewtopic.php?f=3&t=96779

If you read further here, it suggests that a bad craftsman always blames his tools... If they blow off after you mount them, I'm almost certain that the tires were incorrectly mounted. These are one of the few tyres that are (supposedly) safe on a Stans ZTR 340 (which is notorious for having clincher set-ups blow off)

Ok. I get that you think me and all my mates are incompetent. I can live with that. :)

Personally, I've for enough things trying to kill me out there without wasting lives on these tyres. ;) I would consider using them again but only on rims with tighter beads.

Do you want to buy some? I've got a brand new in the box zx and dd, and about 3 almost new ones that were removed after an attempt on someone's life. Make me an offer! I was going to put this in the market place on the weekend.
Once you can climb hills on a bike it's all downhill. :mrgreen:

Hopefully I'll know what that's like..... one day. :shock: :lol:

Image
User avatar
Comedian
 
Posts: 4392
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby jasonc » Wed Dec 05, 2012 12:50 pm

Comedian wrote:
usernameforme wrote:If you read further here, it suggests that a bad craftsman always blames his tools... If they blow off after you mount them, I'm almost certain that the tires were incorrectly mounted. These are one of the few tyres that are (supposedly) safe on a Stans ZTR 340 (which is notorious for having clincher set-ups blow off)

Ok. I get that you think me and all my mates are incompetent. I can live with that. :)


from personal knowledge, Comedian or his mates are not incompetent.
Image
jasonc
 
Posts: 5145
Joined: Thu Feb 24, 2011 2:40 pm
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby usernameforme » Wed Dec 05, 2012 1:04 pm

I guess I'll never know unless I try for myself, I am just sceptical because 2 of the three links you posted sharing other's experiences hint at user error (rim tape too wide or tyre mounted incorrectly). Especially since I've done this myself (got the tube under the bead), albeit with Michelin's.
Can you imagine what I would do if I could do all I can? - Sun Tzu
___________________________
Giant Defy Advanced 0
Shogun Katana
usernameforme
 
Posts: 764
Joined: Thu Jul 14, 2011 7:01 pm
Location: Adelaide

Re: Schwalbe Ultremo blowing off rim

Postby jacks1071 » Wed Dec 05, 2012 11:24 pm

Comedian wrote:
jacks1071 wrote:Comedian are you familiar with the definition of insanity?

Sounds like you've gone to lengths to work out whats causing the issue. I highly recommend you change to some different tyres although I've never had the issue you describe.

I did have some Ultremo casings fail a while ago, about 6 tyres actually. They were replaced under warranty and I never had another issue. If you've ever seen a snake thats eaten a rat or a cat thats what the tyre looked like - big bulges in it.

If you want a really tight tyre, get some tubeless tyres from Hutchinson and run them with tubes. They are TIGHT, the bead on them doesn't stretch.


I have... I've just striped the brand new ultremos and put some conti force and Attacks on. :)


Good move, the last thing I want to read is a crash thread caused by a tyre that blew off your rim.
Our Website is: http://www.pro-liteoz.com Find us on Facebook by searching for "Pro-Lite Australia"
User avatar
jacks1071
 
Posts: 2785
Joined: Thu Aug 20, 2009 9:47 pm
Location: Mackay, QLD

Re: Schwalbe Ultremo blowing off rim

Postby elantra » Mon Dec 10, 2012 7:40 am

jacks1071 wrote:
Comedian wrote:
jacks1071 wrote:Comedian are you familiar with the definition of insanity?

Sounds like you've gone to lengths to work out whats causing the issue. I highly recommend you change to some different tyres although I've never had the issue you describe.

I did have some Ultremo casings fail a while ago, about 6 tyres actually. They were replaced under warranty and I never had another issue. If you've ever seen a snake thats eaten a rat or a cat thats what the tyre looked like - big bulges in it.

If you want a really tight tyre, get some tubeless tyres from Hutchinson and run them with tubes. They are TIGHT, the bead on them doesn't stretch.


I have... I've just striped the brand new ultremos and put some conti force and Attacks on. :)


Good move, the last thing I want to read is a crash thread caused by a tyre that blew off your rim.

And it is now officially SAFE to get on your back wheel for the descent of Coottha.

Is this the end of another extraordinary Comedian thread ?
"Technology gives us much more information but Education is never be able to give us the skill to evaluate it"
User avatar
elantra
 
Posts: 1699
Joined: Tue Jan 13, 2009 5:01 am
Location: Trying to avoid the Brisbane traffic.

Re: Schwalbe Ultremo blowing off rim

Postby Comedian » Mon Dec 10, 2012 8:21 am

elantra wrote:And it is now officially SAFE to get on your back wheel for the descent of Coottha.

Is this the end of another extraordinary Comedian thread ?


As it turns out... not quite :shock: :shock:

I've got my Conti's fitted on the C50's and went out to redcliffe and back Thursday. All good. Saturday morning I pump them up (115psi) ready to roll before my first ever crit track outing. The bike is leaning against the car while I pfaff around. Next thing... BOOOM. :shock: :shock: :shock: :shock: :mrgreen: :mrgreen: :mrgreen:

So, there was much consternation and head scratching. At this point the best theory we have is that the rim tape on the c50's was stopping the tyre sitting down the whole way into the rim. So we removed that and put some cloth tape. It's not a great theory - but it's all I have. :shock: :shock:

Keep in mind there are three sets of wheels here. The C50's have been most problematic. Several people have tried to keep tyres on the back one in particular without success. The c24's it's happened maybe a couple of times. The Mavic kysrium elites it's happened once on and they don't even have rim tape.

Image
Once you can climb hills on a bike it's all downhill. :mrgreen:

Hopefully I'll know what that's like..... one day. :shock: :lol:

Image
User avatar
Comedian
 
Posts: 4392
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby usernameforme » Mon Dec 10, 2012 9:08 am

Comedian wrote:So, there was much consternation and head scratching. At this point the best theory we have is that the rim tape on the c50's was stopping the tyre sitting down the whole way into the rim. So we removed that and put some cloth tape. It's not a great theory - but it's all I have. :shock: :shock:


I remember reading in another thread that this was the case... hopefully problem solved for you :mrgreen:
Can you imagine what I would do if I could do all I can? - Sun Tzu
___________________________
Giant Defy Advanced 0
Shogun Katana
usernameforme
 
Posts: 764
Joined: Thu Jul 14, 2011 7:01 pm
Location: Adelaide

Re: Schwalbe Ultremo blowing off rim

Postby MichaelB » Mon Dec 10, 2012 9:10 am

I've been watching this thread with interest, as I have used the Ultremo ZX for a while, and had no issues (about 4,000km)

Now, mine are the 25C version, so I don't know if that makes any difference. I pump the rears to 100 and the fronts to 90psi.

They have been on the std Kona Payroll wheels that came with the Kona Honky Inc, as well as spent some time on the Reynolds Solitude wheelset that was on the Azzuri Forza Pro that I tested for BNA.

It seems that there may be a problem with the rim rather than the tyres based on the latest post from Comedian. :shock:

I've never actually had a tyre blow off in the 43,000+ km that I have ridden over the last 6 years.

Mauybe it's something to do with Queenslanders, as you guys are a bit different .... :lol:
User avatar
MichaelB
 
Posts: 6824
Joined: Tue Feb 20, 2007 8:29 am
Location: Adelaide, South Australia

Re: Schwalbe Ultremo blowing off rim

Postby jacks1071 » Mon Dec 10, 2012 10:30 am

MichaelB wrote:I've been watching this thread with interest, as I have used the Ultremo ZX for a while, and had no issues (about 4,000km)

Now, mine are the 25C version, so I don't know if that makes any difference. I pump the rears to 100 and the fronts to 90psi.

They have been on the std Kona Payroll wheels that came with the Kona Honky Inc, as well as spent some time on the Reynolds Solitude wheelset that was on the Azzuri Forza Pro that I tested for BNA.

It seems that there may be a problem with the rim rather than the tyres based on the latest post from Comedian. :shock:

I've never actually had a tyre blow off in the 43,000+ km that I have ridden over the last 6 years.

Mauybe it's something to do with Queenslanders, as you guys are a bit different .... :lol:


Do you think maybe the gauge is WRONG in comedian's pump and his 115psi is maybe 150psi ?

He's had this problem now on multiple wheelsets, multiple models & brands of tyre. I can't see how he could be "mounting them wrong" thats not really plausable unless he's greasing his beads with vaseline before installing the tyres!!

What was common between all those wheels and tyres? The user obviously, and maybe the pump?

Comedian - in the meantime I'd drop your pressure down even lower, maybe go by "feel" rather than watching the gauge.
Our Website is: http://www.pro-liteoz.com Find us on Facebook by searching for "Pro-Lite Australia"
User avatar
jacks1071
 
Posts: 2785
Joined: Thu Aug 20, 2009 9:47 pm
Location: Mackay, QLD

Re: Schwalbe Ultremo blowing off rim

Postby Comedian » Mon Dec 10, 2012 11:07 am

I can confirm that my floor pump under-reads by 5psi at 120. I bought a digital gauge and this was indeed one of my early theories.

The tyres have been fitted by two other people using their own pumps to the c50's s and they have had the tyres blow off the back one so I don't think it's my pump. :)

Just to confirm the rim tape on c50s is like that plastic packing tape. The thicker bit I mentioned was where they heat weld it together.
Once you can climb hills on a bike it's all downhill. :mrgreen:

Hopefully I'll know what that's like..... one day. :shock: :lol:

Image
User avatar
Comedian
 
Posts: 4392
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby jacks1071 » Mon Dec 10, 2012 12:56 pm

Comedian wrote:I can confirm that my floor pump under-reads by 5psi at 120. I bought a digital gauge and this was indeed one of my early theories.

The tyres have been fitted by two other people using their own pumps to the c50's s and they have had the tyres blow off the back one so I don't think it's my pump. :)

Just to confirm the rim tape on c50s is like that plastic packing tape. The thicker bit I mentioned was where they heat weld it together.


Pm me your name and address, I'll post you two rolls of 14mm wide rim tape FOC so you can rule it out.

I'd also drop your pressures down to say 105psi rear and 100psi front and keep it under 30km/ph on the decents until you've worked out what is going on.

Don't throw out your collection of Ultremo's just yet.
Our Website is: http://www.pro-liteoz.com Find us on Facebook by searching for "Pro-Lite Australia"
User avatar
jacks1071
 
Posts: 2785
Joined: Thu Aug 20, 2009 9:47 pm
Location: Mackay, QLD

Re: Schwalbe Ultremo blowing off rim

Postby jasonc » Mon Dec 10, 2012 1:02 pm

jacks1071 wrote:
Comedian wrote:I can confirm that my floor pump under-reads by 5psi at 120. I bought a digital gauge and this was indeed one of my early theories.

The tyres have been fitted by two other people using their own pumps to the c50's s and they have had the tyres blow off the back one so I don't think it's my pump. :)

Just to confirm the rim tape on c50s is like that plastic packing tape. The thicker bit I mentioned was where they heat weld it together.


Pm me your name and address, I'll post you two rolls of 14mm wide rim tape FOC so you can rule it out.


before you do that I've got some rim tape that i'll throw at comedian (save on your postage deon). I've got this stuff unused
Image
jasonc
 
Posts: 5145
Joined: Thu Feb 24, 2011 2:40 pm
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby jacks1071 » Mon Dec 10, 2012 1:17 pm

jasonc wrote:before you do that I've got some rim tape that i'll throw at comedian (save on your postage deon). I've got this stuff unused


Thanks Jason - that stuff is good quality.

What I'll send if Comedian wants it is 14mm which will be well away from where the tyre will sit but that being said, I normally use 16mm tape myself as it has less tendancy to move around making it more reliable.

I can't really see this being his problem but we're running out of variables!!

Comedian - I'm wondering if you should toss that digital gauge in your pocket and check your pressures maybe half-way to where you've had them blow off on the road. Get some idea how much the pressure is increasing with heat.
Our Website is: http://www.pro-liteoz.com Find us on Facebook by searching for "Pro-Lite Australia"
User avatar
jacks1071
 
Posts: 2785
Joined: Thu Aug 20, 2009 9:47 pm
Location: Mackay, QLD

Re: Schwalbe Ultremo blowing off rim

Postby WMC1 » Tue Dec 11, 2012 11:40 am

Comedian wrote:I can confirm that my floor pump under-reads by 5psi at 120. I bought a digital gauge and this was indeed one of my early theories.

The tyres have been fitted by two other people using their own pumps to the c50's s and they have had the tyres blow off the back one so I don't think it's my pump. :)

Just to confirm the rim tape on c50s is like that plastic packing tape. The thicker bit I mentioned was where they heat weld it together.


Hi Comedian, i was looking through the thread and noticed that the C50's you are using look the same as mine, are they the 7850 50mm cl's? mine are also set up with 23mm Ultremo ZX tyres and i have not had the issue that you seem to have. i must admit though that the tyres mount very easily to the rim.

i pump mine up to 115psi with no issues. mine have the stock shimano blue rim tape. i may have a closer look at mine. i usually pump the tyre up to around 30 psi then make sure that the tube and bead are correctly seated before going to 115.

let me know if you need me to check anything at my end to compare your setup. Cheers.
Work is something I do in between cycling.

Bikes: 1 x Steel 26” Cruiser, 2 x Alloy Roadies, 1 x Full Carbon Roadie.
It is unfair if only one bike gets all the attention.
User avatar
WMC1
 
Posts: 32
Joined: Mon Nov 26, 2012 9:10 am
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby Comedian » Tue Dec 11, 2012 8:05 pm

WMC1 wrote:
Comedian wrote:I can confirm that my floor pump under-reads by 5psi at 120. I bought a digital gauge and this was indeed one of my early theories.

The tyres have been fitted by two other people using their own pumps to the c50's s and they have had the tyres blow off the back one so I don't think it's my pump. :)

Just to confirm the rim tape on c50s is like that plastic packing tape. The thicker bit I mentioned was where they heat weld it together.


Hi Comedian, i was looking through the thread and noticed that the C50's you are using look the same as mine, are they the 7850 50mm cl's? mine are also set up with 23mm Ultremo ZX tyres and i have not had the issue that you seem to have. i must admit though that the tyres mount very easily to the rim.

i pump mine up to 115psi with no issues. mine have the stock shimano blue rim tape. i may have a closer look at mine. i usually pump the tyre up to around 30 psi then make sure that the tube and bead are correctly seated before going to 115.

let me know if you need me to check anything at my end to compare your setup. Cheers.


Yes mate, spot on. They are 7850 c50's. A lovely wheel to ride on flatter courses and when the wind is not howling. :)
Once you can climb hills on a bike it's all downhill. :mrgreen:

Hopefully I'll know what that's like..... one day. :shock: :lol:

Image
User avatar
Comedian
 
Posts: 4392
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby Comedian » Tue Dec 11, 2012 8:05 pm

WMC1 wrote:
Comedian wrote:I can confirm that my floor pump under-reads by 5psi at 120. I bought a digital gauge and this was indeed one of my early theories.

The tyres have been fitted by two other people using their own pumps to the c50's s and they have had the tyres blow off the back one so I don't think it's my pump. :)

Just to confirm the rim tape on c50s is like that plastic packing tape. The thicker bit I mentioned was where they heat weld it together.


Hi Comedian, i was looking through the thread and noticed that the C50's you are using look the same as mine, are they the 7850 50mm cl's? mine are also set up with 23mm Ultremo ZX tyres and i have not had the issue that you seem to have. i must admit though that the tyres mount very easily to the rim.

i pump mine up to 115psi with no issues. mine have the stock shimano blue rim tape. i may have a closer look at mine. i usually pump the tyre up to around 30 psi then make sure that the tube and bead are correctly seated before going to 115.

let me know if you need me to check anything at my end to compare your setup. Cheers.


Yes mate, spot on. They are 7850 c50's. A lovely wheel to ride on flatter courses and when the wind is not howling. :)
Once you can climb hills on a bike it's all downhill. :mrgreen:

Hopefully I'll know what that's like..... one day. :shock: :lol:

Image
User avatar
Comedian
 
Posts: 4392
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby Comedian » Tue Dec 11, 2012 8:12 pm

Just for the record... my fitting technique is...

1. Fit the tyre.
2. Pump to 60.
3. Check for how well it is seated by spinning it and looking for the indicator lines.
4. Deflate to 10 or so and rock the tyre from sided to side and work my way around the rim. I look for any tube outside the tyre and allow it to move on the bead to rock home.
5. Pump to 60 and recheck.
6. If it all looks good, get my ear muffs and go to 130 or 140 (Baby!).
7. If it's still on the rim a couple of days later back it off to 120 and ride.

Seriously.. I just don't know how to be more careful than this!

Of late I've just been using my c24's that have the same set of ultremos (zx front, DD back) that I've been running for months while I sort this C50 issue. I looked today and noted that the rear is nearly at canvas. I reckon I'll have to confront my demons and change that one in the next week or two. :o
Once you can climb hills on a bike it's all downhill. :mrgreen:

Hopefully I'll know what that's like..... one day. :shock: :lol:

Image
User avatar
Comedian
 
Posts: 4392
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby bosvit » Tue Dec 11, 2012 8:42 pm

Hey guys

Not sure if this helps but;

A friend of mine has a set of American Classic 58mm Carbon clinchers with aluminium track, so very similar to yours. (As far as I am aware they are the old Zipp 404 clincher rims)

He trains around 25k a year and probably about 25%+ on the AC wheels.

He had no problems with them for years and all of a sudden he kept exploding tubes and blowing off tyres.

He had the plastic rim tape. After much faffing around and multiple tyres and tubes (don't stress he can afford it, Abalone diver :roll: ) one of the blokes at Whyalla CC told him to change his rim tape to cloth.

Since the change he has not had a problem and has even fitted and worn out all of the old tyres he was blowing off. Vredestein blah blah's (the better ones anyway)

I've worn out 4 Ultremo R1's and 2 Ultremo ZX's and I am currently running my 3rd and 4th ZX's on American Classic 420's, which are an easier rim to fit to than Mavic Aksiums, and I have not had a problem.
User avatar
bosvit
 
Posts: 1577
Joined: Sat Aug 21, 2010 9:47 pm
Location: Port Lincoln

Re: Schwalbe Ultremo blowing off rim

Postby winstonw » Tue Dec 11, 2012 9:01 pm

Re your fitting technique, I've gone back to shaking my spare tubes around in a bag of Johnson's baby powder before packing.

Other variables to contemplate, esp the problematic C50 (sorry if this has been covered)
- whether the built up wheel BSDs, and inner widths, vary from spec significantly. I have no idea Shimano's margin of error.
- spoke tension.

and an interesting story above re plastic rim tape.
User avatar
winstonw
 
Posts: 1793
Joined: Sun Apr 10, 2011 7:18 pm
Location: Brisbane

Re: Schwalbe Ultremo blowing off rim

Postby bosvit » Tue Dec 11, 2012 9:16 pm

Apparently the theory is that once they have a few km's on them the edge gets sharp and cause the kapop!
User avatar
bosvit
 
Posts: 1577
Joined: Sat Aug 21, 2010 9:47 pm
Location: Port Lincoln

Re: Schwalbe Ultremo blowing off rim

Postby usernameforme » Tue Dec 11, 2012 9:18 pm

could someone please explain to me how spoke tension causes tyres to blow off rims?
Can you imagine what I would do if I could do all I can? - Sun Tzu
___________________________
Giant Defy Advanced 0
Shogun Katana
usernameforme
 
Posts: 764
Joined: Thu Jul 14, 2011 7:01 pm
Location: Adelaide

Re: Schwalbe Ultremo blowing off rim

Postby jacks1071 » Tue Dec 11, 2012 10:05 pm

Comedian wrote:Just for the record... my fitting technique is...

1. Fit the tyre.
2. Pump to 60.
3. Check for how well it is seated by spinning it and looking for the indicator lines.
4. Deflate to 10 or so and rock the tyre from sided to side and work my way around the rim. I look for any tube outside the tyre and allow it to move on the bead to rock home.
5. Pump to 60 and recheck.
6. If it all looks good, get my ear muffs and go to 130 or 140 (Baby!).
7. If it's still on the rim a couple of days later back it off to 120 and ride.

Seriously.. I just don't know how to be more careful than this!

Of late I've just been using my c24's that have the same set of ultremos (zx front, DD back) that I've been running for months while I sort this C50 issue. I looked today and noted that the rear is nearly at canvas. I reckon I'll have to confront my demons and change that one in the next week or two. :o


Step 6 maybe stretching (ruining) your tyres causing your problem. You should never inflate clinchers past 120psi, I don't care what the "max pressure" is on the tyre.

Try this technique

1. Fit tyres
2. Pump to 100-110psi
3. Go ride
Our Website is: http://www.pro-liteoz.com Find us on Facebook by searching for "Pro-Lite Australia"
User avatar
jacks1071
 
Posts: 2785
Joined: Thu Aug 20, 2009 9:47 pm
Location: Mackay, QLD

PreviousNext

Return to The Shed

Who is online

Users browsing this forum: Crawf, DJIntegr8, familyguy



Support BNA
Click for online shops
Torpedo 7 Torpedo7 AU
Ground Effect Ground Effect NZ
Chain Reaction Cycles CRC UK
Wiggle Wiggle UK
Cycling Express Cycling Express
Ebay Ebay AU
ProBikeKit ProBikeKit UK
Evans Cycles Evans Cycles UK
JensonUSA Jenson USA
JensonUSA Competitive Cyclist