Squeaky seatpost - solved!!

Workshop tales, trials and disasters.
Maintenance tips, techniques and myths.
Technical discussion, description and outright lies

Squeaky seatpost - solved!!

Postby Hawkeye » Tue Feb 26, 2008 4:12 pm

When I have the pro-pedal set to locked, the seatpost on my Jekyll squeaks like a honeymooning couple on a rusty spring bed. I've been dealing with it by leaving the pro-pedal on intermediate or full open, but this is draining on long climbs.

What do you good folks suggest for remedying this socially embarassing problem? :oops:
Last edited by Hawkeye on Mon Mar 10, 2008 10:32 am, edited 1 time in total.
Hawkeye
 

by BNA » Tue Feb 26, 2008 4:28 pm

BNA
 

Postby Kalgrm » Tue Feb 26, 2008 4:28 pm

On my XtC frame, I had to grease my seat post, strange as that sounds. Giants are notorious for it, but it's a simple fix.

If that doesn't stop your arse squeaking, the bushes in the rear suspension are the cause. Service and lube them.

Cheers,
Graeme
Think outside the double triangle.
---------------------------------------
My web site: www.scenebyhird.com
---------------------------------------
The Bicycle Transportation Alliance
User avatar
Kalgrm
Super Mod
Super Mod
 
Posts: 9236
Joined: Fri May 25, 2007 5:21 pm
Location: Spearwood, 9km SE of Fremantle, WA

Postby Hawkeye » Tue Feb 26, 2008 6:28 pm

I've tried greasing the seatpost, and it didn't reduce it. I will redo it as soon as I get the time, perhaps I missed something.

It only squeaks as described :oops: when I'm in the saddle. When I stand up to pedal the noise goes.

I'm not strong enough yet to do that all the way up long climbs, and it probably isn't the best way to tackle techy climbs anyway.
Hawkeye
 

Postby Deanj » Tue Feb 26, 2008 6:43 pm

Are you positive its the seat post? The saddle rails squeak on my commuter every time I peddle, but not enough to annoy me..... yet!
Deanj
 
Posts: 1698
Joined: Mon Aug 06, 2007 8:03 pm
Location: Adelaide

Postby stryker84 » Tue Feb 26, 2008 8:49 pm

Okay, first check, is it a suspension post? If so, lube the suspension, that probably will fix it. I've had the same issue with mine on a flat bar roadie (so no suspension forks to squeak), and a liberal application of TriFlow overnight helped. (Mine's set as tight/rigid as it will go now, and hasn't squeaked since).

Also, how sure are you it's the post? Squeaks could be any bit that's rubbing, checked your pro-pedal shox? Since it only squeaks when it's locked out, it may be slipping slightly?
stryker84
 
Posts: 1817
Joined: Thu Sep 28, 2006 8:38 pm
Location: Warrnambool

Postby mikesbytes » Tue Feb 26, 2008 10:08 pm

I have this problem on my OCR2. I rectify it by every so often taking the seat post out, applying grease to it and putting it back in.
A helmet saved my life
User avatar
mikesbytes
Super Mod
Super Mod
 
Posts: 14861
Joined: Thu Dec 01, 2005 10:42 pm
Location: Tempe, Sydney

Postby Mulger bill » Tue Feb 26, 2008 10:56 pm

The squeak disappearing when you stand strongly points to seatpost or saddle rails, it could be in the BB tho' and only shows when the extra weight and force of standing pedalling occurs.

Is the squeak consistent with a certain place in the crank revolution?
Have you checked the main pivot bearings or the shock mounting bushes?
Could the propedal lever be rubbing on something in the closed position?

Good luck

Shaun
...whatever the road rules, self-preservation is the absolute priority for a cyclist when mixing it with motorised traffic.
London Boy 29/12/2011
User avatar
Mulger bill
Super Mod
Super Mod
 
Posts: 26011
Joined: Sun Sep 24, 2006 2:41 pm
Location: Sunbury Vic

Postby Hawkeye » Wed Feb 27, 2008 10:04 am

Mulger bill wrote:The squeak disappearing when you stand strongly points to seatpost or saddle rails, it could be in the BB tho' and only shows when the extra weight and force of standing pedalling occurs.

Is the squeak consistent with a certain place in the crank revolution?
Have you checked the main pivot bearings or the shock mounting bushes?
Could the propedal lever be rubbing on something in the closed position?


Yeh, it was my first thought too that it was the shock or shock bushings. But the disappearance of the noise as soon as I take the load off the seat indicates I think that it probably isn't either of those things. BB is a thought, but I don't get the noise when propedal is set to intermediate or full open regardless of whether seated or when standing.

I only get the noise when seated and the shock is locked. The creaking noise (to be more accurate) occurs with a certain tone when I apply max load to the cranks on the downstroke between 1:30 and four o'clock (either leg) and a slightly different tone when the the load is reduced slightly over the rest of the stroke. Creaks like a spring bed: ee-o'-ee-o'-ee-o' ... :oops:

Propedal lever definitely isn't rubbing. I have the shock canted slightly to one side so I can get to the shrader valve, so if it's going to rub it would be on the fully open setting.

The seatpost is a Ritchey alloy and the saddle a Fi'zi:k Plateau. Seatpost is not suspended. Suspended rear end takes care of that.

Here's the bike:

Image
Hawkeye
 

Postby Kalgrm » Wed Feb 27, 2008 11:00 am

J.R., Don't discount the other places where these creaks may originate. Just because it only happens when you're seated, it doesn't necessarily indicate the seat area is the problem.

For instance, I once had a creak which I was certain was coming from the seat area, but it turned out to be the bar clamp on the head stem not being tight enough. It only creaked when I was seated because I was putting exactly the right amount of torsion into the bars when seated. When standing, I pulled too much for it to creak or I was pulling it from the wrong direction.

So the moral of the story is to check everything. Sorry. :cry:

Cheers,
Graeme
Think outside the double triangle.
---------------------------------------
My web site: www.scenebyhird.com
---------------------------------------
The Bicycle Transportation Alliance
User avatar
Kalgrm
Super Mod
Super Mod
 
Posts: 9236
Joined: Fri May 25, 2007 5:21 pm
Location: Spearwood, 9km SE of Fremantle, WA

Postby Hawkeye » Mon Mar 10, 2008 10:33 am

I found the reason for my creaky seatpost over the weekend. As was suggested by Graeme, it wasn't the seatpost at all.

It turned out to be the saddle. The sockets where the seatrails hook into at each end had accumulated dust. Washing out with water and applying a small amount of chainlube brought ... silence! 8)
Hawkeye
 


Return to The Shed

Who is online

Users browsing this forum: Phil4286



Popular Bike Shops
Torpedo 7 Torpedo7 AU
Ground Effect Ground Effect NZ
Chain Reaction Cycles CRC UK
Wiggle Wiggle UK
Ebay Ebay AU

“Bicycles BNA Twitter
“Bicycles BNA Facebook
“Google+ BNA Google+
“Bicycles BNA Newsletter

> FREE BNA Stickers
> BNA Cycling Kit