Magellan Cyclo 505

CycloTron
Posts: 115
Joined: Mon Oct 17, 2016 9:17 am

Re: Magellan Cyclo 505

Postby CycloTron » Sun Feb 12, 2017 12:38 pm

Great! Thanks for the heads up.
Been monitoring the Magellan software update page for ages, until I recently gave up...

User avatar
cancan64
Posts: 1511
Joined: Tue Oct 22, 2013 9:13 pm
Location: Auckland

Re: Magellan Cyclo 505

Postby cancan64 » Thu Feb 16, 2017 10:35 am

Decided to use my repaired/replaced 505 this week... no auto update to Strava although it has uploaded to endomondo... I unlinked accounts...re linked accounts...used magellan web site and mioshare website and no go...and then this morning was raining and now the screen is unresponsive... 5 rides it lasted for... back to using the garmin which is also not working as well since it was replaced under warranty
“Some say he isn’t machine washable, and all his potted plants are called ‘Steve’.

Abby
Posts: 362
Joined: Fri May 21, 2010 11:41 am

Re: Magellan Cyclo 505

Postby Abby » Thu Feb 16, 2017 10:37 am

Where can these be purchased - haven't seen them around for a long time?

Sully
Posts: 17
Joined: Sat Oct 15, 2016 10:41 am

Re: Magellan Cyclo 505

Postby Sully » Thu Feb 16, 2017 11:35 am

My Cuclo wouldn't acquire satellites last week. I looked in the folders and there were some crazy folder and file names. That didn't look rignt.
Thanks to this tjread I had a back up. I checked there and it looked completely different. The files cant be deleted sl ive renamed the folder they're in and copied the folder from my backup accross.

Thanks to everyone here for letting people know about this device. I would have been stuffed without you.

mikeyg63
Posts: 134
Joined: Fri Apr 18, 2014 4:21 pm

Re: Magellan Cyclo 505

Postby mikeyg63 » Thu Feb 16, 2017 1:24 pm

cancan64 wrote:Decided to use my repaired/replaced 505 this week... no auto update to Strava although it has uploaded to endomondo... I unlinked accounts...re linked accounts...used magellan web site and mioshare website and no go...and then this morning was raining and now the screen is unresponsive... 5 rides it lasted for... back to using the garmin which is also not working as well since it was replaced under warranty


To be frank, I had nothing but trouble with the Magellan Cyclo 505. I gave up on it a year or so ago. I recall it seizing up when it rained and at other times, not linking to other sensors properly.

Other people may have had more success than me but because of my experience I couldn't recommend people buy this device.

Cheers

User avatar
PiratePete
Posts: 628
Joined: Thu Sep 25, 2014 9:04 am
Location: Brisbane, Australia
Contact:

Re: Magellan Cyclo 505

Postby PiratePete » Thu Feb 16, 2017 2:42 pm

Abby wrote:Where can these be purchased - haven't seen them around for a long time?


They're becoming scarce. A couple of weeks ago JB HiFi still showed a couple down south, Ebay has at least one new one (be careful as maps are country specific and cannot be changed, stick with AU/NZ models. Or when mine is replaced. We can chat about that if your keen as I really don't need two of them. PM me on insta if your interested.

Paul, I will say though, as they're disappearing from the shops and with the lack of updates, I think the product is defunct. So don't purchase one thinking that you will see updates in the future. Real shame as I've found it to be an excellent navigator, it's taken me to all sorts of places without fuss.
2015 Specialized Diverge Carbon Expert
2013 Giant Reign MTB.
Pirate Pete on Instagram

User avatar
cancan64
Posts: 1511
Joined: Tue Oct 22, 2013 9:13 pm
Location: Auckland

Re: Magellan Cyclo 505

Postby cancan64 » Fri Feb 17, 2017 10:29 am

Must be something in the rain over here...with the 505 dead from yesterdays rain I switched to my recently replaced Garmin 1000 which lasted 15km in this mornings rain... down to my watch now...
“Some say he isn’t machine washable, and all his potted plants are called ‘Steve’.

User avatar
RonK
Posts: 9736
Joined: Mon Aug 24, 2009 2:08 pm
Location: Brisbane, Queensland
Contact:

Re: Magellan Cyclo 505

Postby RonK » Fri Feb 17, 2017 10:38 am

cancan64 wrote:Must be something in the rain over here...with the 505 dead from yesterdays rain I switched to my recently replaced Garmin 1000 which lasted 15km in this mornings rain... down to my watch now...

Apparently the rain over there is wetter... :lol:

There is certainly a lot of it at times... :wink:
Cycle touring blog and tour journals: whispering wheels...

User avatar
bane
Posts: 118
Joined: Fri Jan 22, 2016 4:57 pm

Re: Magellan Cyclo 505

Postby bane » Fri Feb 17, 2017 9:06 pm

Not sure what I've done wrong, but mine wouldn't update. The Cycle Agent still thinks 4.2.6 is the current version. Tried finding new updates and just get the "device already up to date" response.
Image

defy1
Posts: 712
Joined: Thu Jun 06, 2013 10:40 pm

Re: Magellan Cyclo 505

Postby defy1 » Sat Feb 18, 2017 7:35 am

cancan64 wrote:Decided to use my repaired/replaced 505 this week... no auto update to Strava although it has uploaded to endomondo... I unlinked accounts...re linked accounts...used magellan web site and mioshare website and no go...and then this morning was raining and now the screen is unresponsive... 5 rides it lasted for... back to using the garmin which is also not working as well since it was replaced under warranty


yes mine does not auto update to strava anymore since the update. Logged a ticket to Magellan and they report others have the same issue and they are currently investigating.

User avatar
PiratePete
Posts: 628
Joined: Thu Sep 25, 2014 9:04 am
Location: Brisbane, Australia
Contact:

Re: Magellan Cyclo 505

Postby PiratePete » Sat Feb 18, 2017 11:30 am

I received a replacement for my water logged 505, it came with 4.4 installed so I gave it a crack. My first impressions:

Strava segments just worked, I starred two for today, first one a 15km segment with intersections and turns. It navigated me without fault. The only issue is that with a timer on the screen showing RED for 'too slow' I was compelled to push a little harder. Alright, so I gave it all I had, a 15km sprint! Guess that's what it's for... Second segment was just over 1.3km and one which I created to measure my fatigue level as it's a climb which I regularly do on my way home from some of my longer routes. I've wanted this KOM as it's MY segment... Today after having already ridden 70km (including the 15km sprint) I gave it my all as the timer was showing a slim GREEN figure. OMGosh it's a good thing it didn't display my HR! I just made it! Beat my previous PR by 12 seconds and YES, KOM (just)...

Note on Strava Segments, they won't for some silly reason sync to the 505 via WiFi. You must connect via USB and the Cyclo Agent... Ridiculous.

Fonts, extra data screens, improved responsiveness, all really good improvements. Particularly the new fonts, and bolding of the text within the data screens, much easier to see in the predawn murk (without backlighting).

BUT, and this is a very big B U T

There was a random intermittent bug introduced at 4.2 which yielded the device unusable for my training purposes. I reported this at the time to MagellanAU and I worked with them to give them all the data they wanted. At the time they replaced the cyclo which I had updated to 4.2.4 with one back on 4.1 as a temporary work around till the next release... TWO YEARS I'VE WAITED, TWO YEARS! So on my very first ride with 4.4, the same bug is still there. In 72km ride with a total of 10 stops (traffic lights, coffee, etc), the device failed to detect the stop 4 times and thus continued to count time and reduced the average active speed. The biggest noticeable one was my mid ride coffee stop, where I even paused recording, and my average speed dropped from 29.9kmh to 22.4kmh.

Strava corrects this when it works it's magic (yes I had to do a manual upload too BTW), however I use Training Peaks (WiFi sync and linkage still working) and it does not massage the figures like Strava. So to correct the statistics, I've needed to carefully view the ride and find where the issue has occurred and delete these sections to reach correct figures.

As I said, I worked with Magellan to resolve this one, I've waited two years for the fix, and it isn't. All the new features are nice, but it appears that I'll be rolling back to 4.1 with it's 2014 maps, because I can't see Magellan releasing any fixes anytime soon, if ever.

I've been one of this products biggest advocates, I still believe it to be the best navigator out there, but by crikey, a two year wait for nothing.
2015 Specialized Diverge Carbon Expert
2013 Giant Reign MTB.
Pirate Pete on Instagram

Chiips
Posts: 9
Joined: Mon Dec 12, 2016 3:55 pm

Re: Magellan Cyclo 505

Postby Chiips » Sat Feb 18, 2017 1:08 pm

defy1 wrote:
cancan64 wrote:Decided to use my repaired/replaced 505 this week... no auto update to Strava although it has uploaded to endomondo... I unlinked accounts...re linked accounts...used magellan web site and mioshare website and no go...and then this morning was raining and now the screen is unresponsive... 5 rides it lasted for... back to using the garmin which is also not working as well since it was replaced under warranty


yes mine does not auto update to strava anymore since the update. Logged a ticket to Magellan and they report others have the same issue and they are currently investigating.


Auto update to Strava also hasn't been working for me since update. However it miraculously did this morning! Uncertain if it had anything to do with what I did earlier:

- Previously I tried unlink/re-link Strava from Magellan dashboard ==> no good. I can't remember if it asked for Strava login details.
- Today I had signed into Strava and left it open.
- Then in another window I linked Strava via the Mioshare dashboard, and it DID NOT ask for my Strava login details, just an authorise button.
- About 30 secs later, this morning's ride which was wifi uploaded about 20mins earlier appeared!

Coincidence, random, or have Magellan/Mio tweaked something on their end?

User avatar
PiratePete
Posts: 628
Joined: Thu Sep 25, 2014 9:04 am
Location: Brisbane, Australia
Contact:

Re: Magellan Cyclo 505

Postby PiratePete » Sat Feb 18, 2017 5:39 pm

Chiips wrote:Coincidence, random, or have Magellan/Mio tweaked something on their end?


What time? I uploaded mine at 08:21 EST and immediately received notification from Training Peaks, I ended up manually uploading to Strava around 10am.
2015 Specialized Diverge Carbon Expert
2013 Giant Reign MTB.
Pirate Pete on Instagram

Chiips
Posts: 9
Joined: Mon Dec 12, 2016 3:55 pm

Re: Magellan Cyclo 505

Postby Chiips » Sat Feb 18, 2017 8:16 pm

PiratePete wrote:
Chiips wrote:Coincidence, random, or have Magellan/Mio tweaked something on their end?


What time? I uploaded mine at 08:21 EST and immediately received notification from Training Peaks, I ended up manually uploading to Strava around 10am.


PP, would've been around 11:45am AEST when I wifi synced. Maybe they fixed it after 10am today...?

User avatar
PiratePete
Posts: 628
Joined: Thu Sep 25, 2014 9:04 am
Location: Brisbane, Australia
Contact:

Re: Magellan Cyclo 505

Postby PiratePete » Sun Feb 19, 2017 2:28 pm

Thanks @Chiips I won't be out till Tuesday so fingers crossed.
2015 Specialized Diverge Carbon Expert
2013 Giant Reign MTB.
Pirate Pete on Instagram

canadiancyclist
Posts: 2
Joined: Mon Feb 20, 2017 10:39 am

Re: Magellan Cyclo 505

Postby canadiancyclist » Mon Feb 20, 2017 10:50 am

Hi Guys,

I've run into a few problems with my 505.

First, when I "check for updates" through CycloAgent (2.1.37.2), it fails to connect to MagellanShare servers. Is anyone else having this problem? I've even tried downloading different versions of CycloAgent (2.1.39.2) (2.1.47.2) but no luck with those either.

The reason that I need to connect to the server is that I had to restore my device. I deleted all the data in the system folder, and when I go to restore the device, it can't connect to re-download the files. I've now got a bricked 505, so my next question is.... does anyone know where I can manually download all the software for either version 4.2.4 or version 4.4? Thanks so much.

Chiips
Posts: 9
Joined: Mon Dec 12, 2016 3:55 pm

Re: Magellan Cyclo 505

Postby Chiips » Mon Feb 20, 2017 11:56 am

@canadiancyclist

Looks like their servers are currently out of action. Give it some time and try again later.
Usually no problems connecting to their servers, but this morning didn't work for me either. Guessing could be a temporary issue.

@PiratePete, next ride Tuesday as well for me.... fingers crossed indeed.

canadiancyclist
Posts: 2
Joined: Mon Feb 20, 2017 10:39 am

Re: Magellan Cyclo 505

Postby canadiancyclist » Tue Feb 21, 2017 4:14 am

Chiips wrote:@canadiancyclist

Looks like their servers are currently out of action. Give it some time and try again later.
Usually no problems connecting to their servers, but this morning didn't work for me either. Guessing could be a temporary issue.



You were right. I tried a few hours later and servers were back up. Thank you!

User avatar
PiratePete
Posts: 628
Joined: Thu Sep 25, 2014 9:04 am
Location: Brisbane, Australia
Contact:

Re: Magellan Cyclo 505

Postby PiratePete » Tue Feb 21, 2017 9:13 am

Chiips wrote:@PiratePete, next ride Tuesday as well for me.... fingers crossed indeed.


Still no sign of my ride on Strava 1h45m after TP received this mornings ride. Still broken.
2015 Specialized Diverge Carbon Expert
2013 Giant Reign MTB.
Pirate Pete on Instagram

Chiips
Posts: 9
Joined: Mon Dec 12, 2016 3:55 pm

Re: Magellan Cyclo 505

Postby Chiips » Tue Feb 21, 2017 1:01 pm

@PP, both my rides today successfully showed up in Strava! Synced about 12:30pm and both appeared a few minutes later.

I'm guessing it might have something to do with linking Strava via Mio website??? Do you have it linked in Mio, or just Magellan website?

User avatar
PiratePete
Posts: 628
Joined: Thu Sep 25, 2014 9:04 am
Location: Brisbane, Australia
Contact:

Re: Magellan Cyclo 505

Postby PiratePete » Tue Feb 21, 2017 1:44 pm

@chiips linkage via magellancyclo.com, I unlinked and linked it again due to this ussue as that seems to be the fix when it fails for TP. I've never linked it via Mio as that site is for EU.

Question: did you sync via WiFi, or via the agent? I do it via WiFi.
2015 Specialized Diverge Carbon Expert
2013 Giant Reign MTB.
Pirate Pete on Instagram

Chiips
Posts: 9
Joined: Mon Dec 12, 2016 3:55 pm

Re: Magellan Cyclo 505

Postby Chiips » Tue Feb 21, 2017 2:25 pm

@PP I sync via Wifi as well.

I made some adjustments on the bike earlier, did a quick 3km test ride, and Strava received it again no issues. As per post earlier, it all started working for me after I linked Strava on Mioshare. Perhaps after the latest update 4.4.7, we're all considered EU?

I notice that Mioshare.com and Magellancyclo.com dashboards look practically the same, same ride details, same login details. Just the "News" link differ. I reckon you should try linking Strava on Mioshare and test it?

brokenbus
Posts: 592
Joined: Sat Mar 13, 2010 7:12 pm
Location: Blackhead NSW

Re: Magellan Cyclo 505

Postby brokenbus » Tue Feb 21, 2017 3:11 pm

I am not getting strava connection either since I updated.
Image

User avatar
PiratePete
Posts: 628
Joined: Thu Sep 25, 2014 9:04 am
Location: Brisbane, Australia
Contact:

Re: Magellan Cyclo 505

Postby PiratePete » Tue Feb 21, 2017 8:23 pm

Chiips wrote:@PP I sync via Wifi as well.
...
I notice that Mioshare.com and Magellancyclo.com dashboards look practically the same, same ride details, same login details. Just the "News" link differ. I reckon you should try linking Strava on Mioshare and test it?


You could be onto something there. The linkage between the two sites could possibly be an issue. For years now I've purely seen the different URL's to be just a DNS thing as the the site's are basically the same and are obviously pulling data from the same database. However I've logged in to Mioshare and sure enough, my synchronization settings show Strava disabled, and TP enabled. Checking Magellancyclo and both are enabled. I've enabled Strava at Mioshare and we will see what happens on Thursday (next opportunity to get out on the bike).

Thanks Chiips!
2015 Specialized Diverge Carbon Expert
2013 Giant Reign MTB.
Pirate Pete on Instagram

brokenbus
Posts: 592
Joined: Sat Mar 13, 2010 7:12 pm
Location: Blackhead NSW

Re: Magellan Cyclo 505

Postby brokenbus » Wed Feb 22, 2017 11:19 am

I enabled Strava on Mio Last night and the ride was waiting with strava this morning. Anyone else have success?

PiratePete wrote:
Chiips wrote:@PP I sync via Wifi as well.
...
I notice that Mioshare.com and Magellancyclo.com dashboards look practically the same, same ride details, same login details. Just the "News" link differ. I reckon you should try linking Strava on Mioshare and test it?


You could be onto something there. The linkage between the two sites could possibly be an issue. For years now I've purely seen the different URL's to be just a DNS thing as the the site's are basically the same and are obviously pulling data from the same database. However I've logged in to Mioshare and sure enough, my synchronization settings show Strava disabled, and TP enabled. Checking Magellancyclo and both are enabled. I've enabled Strava at Mioshare and we will see what happens on Thursday (next opportunity to get out on the bike).

Thanks Chiips!
Image

Who is online

Users browsing this forum: No registered users