Garmin 520 Intermittently Loses Satellites

User avatar
mogwaiboi
Posts: 377
Joined: Sun Jun 01, 2008 9:24 am
Location: Melbourne

Garmin 520 Intermittently Loses Satellites

Postby mogwaiboi » Thu Mar 22, 2018 8:42 pm

Hi All

My Garmin 520 (out of the blue) has started to intermittently lose satellite reception during rides, for minutes at a time. It happens in open areas. Latest firmware 12.50, I've reset it and even formatted it, but the issue still persists. Any ideas (besides buying a Wahoo Elemnt Bolt)?

Thanks!
In search of up - Hells 500

User avatar
RonK
Posts: 10077
Joined: Mon Aug 24, 2009 2:08 pm
Location: Brisbane, Queensland
Contact:

Re: Garmin 520 Intermittently Loses Satellites

Postby RonK » Thu Mar 22, 2018 11:16 pm

Are you using a GoPro?
Cycle touring blog and tour journals: whispering wheels...

User avatar
mogwaiboi
Posts: 377
Joined: Sun Jun 01, 2008 9:24 am
Location: Melbourne

Re: Garmin 520 Intermittently Loses Satellites

Postby mogwaiboi » Fri Mar 23, 2018 8:13 am

RonK wrote:Are you using a GoPro?


No I'm not
In search of up - Hells 500

Shred11
Posts: 86
Joined: Sun May 18, 2014 12:32 pm
Location: Launceston

Re: Garmin 520 Intermittently Loses Satellites

Postby Shred11 » Fri Mar 23, 2018 8:19 am

Sometimes electronics on your bike can interfere with reception of the GPS signal.

If you have a light on the front of the bike, see if switching it off (or moving it, or substituting a different light etc) fixes the problem.

RobertL
Posts: 539
Joined: Wed Feb 17, 2016 3:08 pm
Location: Brisbane

Re: Garmin 520 Intermittently Loses Satellites

Postby RobertL » Fri Mar 23, 2018 11:41 am

Shred11 wrote:Sometimes electronics on your bike can interfere with reception of the GPS signal.

If you have a light on the front of the bike, see if switching it off (or moving it, or substituting a different light etc) fixes the problem.


Yeah - I was given a basic video camera for Xmas. When I mounted it on my bike it blocked the GPS reception on my Garmin. Not totally, but I had trouble acquiring satellites, and they'd drop out occasionally. I moved the video camera as far away and as low as I could (sensibly) and it seems to have worked.
Image

User avatar
mogwaiboi
Posts: 377
Joined: Sun Jun 01, 2008 9:24 am
Location: Melbourne

Re: Garmin 520 Intermittently Loses Satellites

Postby mogwaiboi » Sat Mar 24, 2018 8:56 pm

Unfortunately it occurs without any lights on the bike :cry:
In search of up - Hells 500

1Rowdy1
Posts: 49
Joined: Mon Jan 02, 2017 10:51 am

Re: Garmin 520 Intermittently Loses Satellites

Postby 1Rowdy1 » Sun Mar 25, 2018 12:09 pm

I have had the same problem, started on Tuesday

User avatar
mogwaiboi
Posts: 377
Joined: Sun Jun 01, 2008 9:24 am
Location: Melbourne

Re: Garmin 520 Intermittently Loses Satellites

Postby mogwaiboi » Mon Mar 26, 2018 8:41 pm

1Rowdy1 wrote:I have had the same problem, started on Tuesday


Interesting, I read somewhere that some people were having issues with Glonass recently so they turned that off and just left GPS on. I'm going to try that and see if it makes any difference...
In search of up - Hells 500

Who is online

Users browsing this forum: uart