Page 1 of 1

Avid Juicy 3 problems, Pls Help?

Posted: Sat Dec 13, 2008 2:45 pm
by brendancg
Dear all

I am new to the MTB riding, after riding road for a couple of years, I am now doing the odd off road ride and planning for some competition. However, I am having dramas with my Avid Juicy 3 hydaulic brakes. On the rear brake fluid reservoir, when I pull the lever to use the brakes a small amount of fluid leaks from the gap between the plastic cover and the bottom. I have tried tightening the screws however this only slowed the leak. How do I fix this problem, I am going on a long ride on Friday with a mate (4 hours at least and I don't want to run out of rear brake.

Posted: Sat Dec 13, 2008 4:11 pm
by Kalgrm
G'day Brendan,

That sounds to me like you've blown a seal (I hope you weren't eating an ice-cream though ... ;)).

If the brakes are new, take them back to the supplier for a warranty replacement. If they are older, you'll either need to find a set of seals somewhere or buy new brakes.

Cheers,
Graeme

Posted: Sat Dec 13, 2008 8:44 pm
by brendancg
I thought as much. Thanks for that Graeme. I have looked around and there isn't a parts kit for the Juicy 3's there is for the 5 and 7's so I will be taking it back to the shop for a repair. Haven't taken it back there as it is a long drive.

Brendan

Posted: Sun Dec 14, 2008 4:11 pm
by Spiza
If it's just leaking from the reservoir cover maybe there's just some crap between the surfaces or the rubber seal isn't sitting properly. Try removing the cover and thoroughly clean both surfaces and the rubber seal. Worth a try :)