29.09.2009 Forum and site dead - here we go again

News from Bicycles Network Australia and the Australian Cycling Forums

29.09.2009 Forum and site dead - here we go again

Postby AUbicycles » Tue Sep 29, 2009 9:06 pm

Hello.
I am sorry to announce that the forum and site were down (29.09.2009) from about 8:20pm to 8:58pm (Aus EST).
At about 8:26pm I put in an urgent ticket to the host and it is not yet answered, after about half an hour the server restarts anyway.

The error on the site and forum was MySQL: ERROR 1040: Too many connections.
I can't understand why this is happening as connections are set at unlimited (from what I can see in the server settings) and I couldn't see that there was an excessive amount of traffic on the site at the time it died. If anyone is aware of how many users were listed as being on the site just before it died, please let me know.

Yet again I will have a look and see if I can pinpoint the cause and see what it means to resolve the problem.

Cheers
Christopher
User avatar
AUbicycles
Site Admin
Site Admin
 
Posts: 9303
Joined: Tue Aug 23, 2005 2:14 am
Location: Sydney

by BNA » Tue Sep 29, 2009 9:17 pm

BNA
 

Re: 29.09.2009 Forum and site dead - here we go again

Postby Mulger bill » Tue Sep 29, 2009 9:17 pm

Same error here Christopher, good thing I did the CtrlC thing...

No idea of members aboard tho', there was about 24 when I logged on about 1900.

Shaun
...whatever the road rules, self-preservation is the absolute priority for a cyclist when mixing it with motorised traffic.
London Boy 29/12/2011
User avatar
Mulger bill
Super Mod
Super Mod
 
Posts: 26210
Joined: Sun Sep 24, 2006 2:41 pm
Location: Sunbury Vic

Re: 29.09.2009 Forum and site dead - here we go again

Postby Rockford » Tue Sep 29, 2009 9:51 pm

Yeah about 20 odd, and about 7 bots/spiders I wonder if one of them went haywire and maxed out the connections.
Image
User avatar
Rockford
 
Posts: 903
Joined: Sun Jan 11, 2009 12:37 pm
Location: Sydney

Re: 29.09.2009 Forum and site dead - here we go again

Postby AUbicycles » Tue Sep 29, 2009 11:16 pm

Thanks for the feedback...

Well done Shaun, ctrl C .... or Apple C is a lifesaver!
User avatar
AUbicycles
Site Admin
Site Admin
 
Posts: 9303
Joined: Tue Aug 23, 2005 2:14 am
Location: Sydney

Re: 29.09.2009 Forum and site dead - here we go again

Postby provoked » Tue Oct 13, 2009 2:44 pm

I'm not 100% certain, but I think it may have happened again. Got a MySQL Error, forums weren't available for a short while.

Can't remember exact error, sorry.
Giant TCR Alliance 2 '09

The mind is its own place, and in itself, can make heaven of Hell, and a hell of Heaven. - John Milton
User avatar
provoked
 
Posts: 1110
Joined: Fri Nov 07, 2008 9:01 pm
Location: Mebourne - North

Re: 29.09.2009 Forum and site dead - here we go again

Postby Aushiker » Tue Oct 13, 2009 2:54 pm

Hi

Yep it is back or rather was at around 12:30 PM GMT + 8. Email sent.

Regards
Andrew
User avatar
Aushiker
 
Posts: 20431
Joined: Tue Jun 05, 2007 1:55 pm
Location: Fremantle, WA

Re: 29.09.2009 Forum and site dead - here we go again

Postby provoked » Tue Oct 13, 2009 2:57 pm

Not sure if I have my timezones confused but mine only happened a bit before my post, i.e. 3:40PM ish
Giant TCR Alliance 2 '09

The mind is its own place, and in itself, can make heaven of Hell, and a hell of Heaven. - John Milton
User avatar
provoked
 
Posts: 1110
Joined: Fri Nov 07, 2008 9:01 pm
Location: Mebourne - North

Re: 29.09.2009 Forum and site dead - here we go again

Postby Aushiker » Tue Oct 13, 2009 2:58 pm

provoked wrote:Not sure if I have my timezones confused but mine only happened a bit before my post, i.e. 3:40PM ish


That is about right assuming you are on eastern states DST. It was out for around 10 minutes.

Andrew
User avatar
Aushiker
 
Posts: 20431
Joined: Tue Jun 05, 2007 1:55 pm
Location: Fremantle, WA

Re: 29.09.2009 Forum and site dead - here we go again

Postby provoked » Tue Oct 13, 2009 3:02 pm

Aushiker wrote:
provoked wrote:Not sure if I have my timezones confused but mine only happened a bit before my post, i.e. 3:40PM ish


That is about right assuming you are on eastern states DST. It was out for around 10 minutes.

Andrew


:P Apologies Andrew - told you my zones would have been confused :oops:
Giant TCR Alliance 2 '09

The mind is its own place, and in itself, can make heaven of Hell, and a hell of Heaven. - John Milton
User avatar
provoked
 
Posts: 1110
Joined: Fri Nov 07, 2008 9:01 pm
Location: Mebourne - North

Re: 29.09.2009 Forum and site dead - here we go again

Postby AUbicycles » Tue Oct 13, 2009 10:35 pm

Timing may have not been identical for all - reason being is that if you already have a connection with the site that it being maintained then it may stay up - while new users or users who have their connections refreshed are thrown off.

Thanks for the mail Andrew - it was the start of a bunch of problems on the site.
User avatar
AUbicycles
Site Admin
Site Admin
 
Posts: 9303
Joined: Tue Aug 23, 2005 2:14 am
Location: Sydney

Re: 29.09.2009 Forum and site dead - here we go again

Postby steveoc » Tue Jan 19, 2010 8:30 am

Not sure what your hosting arrangement is - but next time this happens, ideally you could login to the server via ssh, and get into mysql manually (mysql reserves a connection for the supervisor account even when maxed out), and then use SHOW PROCESSLIST to diagnose the issue ?
Image
2010 GT GTR Carbon Team
2008 Avanti Giro, Lime Green
"Middle Age" postponed for another year ...
User avatar
steveoc
 
Posts: 350
Joined: Wed Apr 30, 2008 1:19 pm
Location: Glenelg, Adelaide


Return to Info / announcements

Who is online

Users browsing this forum: No registered users


PM Issues
Known Bug - error message displayed when sending PM's caused by tapatalk. Read more


Popular Bike Shops
Wiggle Wiggle UK
Ground Effect Ground Effect NZ
Ebay Ebay AU
Chain Reaction Cycles CRC UK

“Bicycles BNA Twitter
“Bicycles BNA Facebook
“Google+ BNA Google+
“Bicycles BNA Newsletter

> FREE BNA Stickers
> BNA Cycling Kit