#$%! Garmin updates

#$%! Garmin updates

Postby Newcastle Dave » Wed May 14, 2014 1:44 pm

So, I was given a Garmin 510 a month or so back. Has been working fine with just the odd glitch until this morning

I upgraded the firmware last Friday (yeh yeh I know, never update) as the new Garmin Express kept telling me it was out of date. I go to start it for my morning commute, it doesnt seem to be displaying anything. I hit start and it beeps but doesnt display the page I had setup, just the initial screen. I hit it again and it asks if I want to save or discard the ride so it seems to be recording OK. I change activity profiles to another I had customised, same thing.

So I set off without it running, get to a red light and while I am waiting for the green I had another go. I find that the "Race" activity profile works, so I set it to that and continue.

I get to work and have a bit more of a look. The Train profile that I had customised and the "Commute" one I had created have all had their page set to display zero items. I try and reset, seems to work Ok but after save and going back in they are displaying zero items again.

So now i have deleted those activity pofiles and recreated them - if it looses those I will start to get cranky :x

Anyone else had any similar problems ?
Newcastle Dave
 
Posts: 51
Joined: Tue Dec 17, 2013 6:17 pm

by BNA » Wed May 14, 2014 2:32 pm

BNA
 

Re: #$%! Garmin updates

Postby SquareWheels » Wed May 14, 2014 2:32 pm

I have the latest updates/firmware and all is good. Maybe you just have a crap unit if you also been getting the "odd glitch".
I don't expect odd glitches on a unit that costs as much as it does.
SquareWheels
 
Posts: 104
Joined: Tue Feb 19, 2013 11:11 pm
Location: Fremantle, WA

Re: #$%! Garmin updates

Postby march83 » Wed May 14, 2014 3:10 pm

i recommend backing up the entire device from time to time, particularly when updating, but also because of known bugs that can destroy your configuration files (for example, running the battery completely flat). all the config stuff like bikes, profiles and other settings are wrapped up in xml files or gpx files on the accessible part of the file system so they can be manually restored if required.

you're not the only one with this problem though - there were a handful of similar reports on the garmin forum, though it didn't sound widespread. my advice for future upgrades would be to check the change notes of the new revision - if there's nothing in them that sounds relevant to you and the device is otherwise ok, then don't bother upgrading.
march83
 
Posts: 184
Joined: Mon Apr 29, 2013 10:41 pm

Re: #$%! Garmin updates

Postby TcrNick » Wed May 14, 2014 3:43 pm

I had a similiar problem with my Garmin 510 towards the end of feb.

After saving my ride, i tried to view the summary and it wouldnt load the ride (was annoyed as it was after a race). The garmin was unresponsive while it was stuck on loading the ride, and i had to hold the power button down to turn it off and on to use it. Once i set off for home I noticed that the 'Train' screen had vanished and only the 'Race' screen was showing. At home, i tried uploading to strava, and strava reported that file was corrupt. I reset my garmin to factory settings, and saw there was an update (which i ran) and since then had no problems.

But i have just reminded myself to make a backup of all my screens just incase this does happen again.
TcrNick
 
Posts: 2
Joined: Wed Mar 19, 2014 12:35 pm

Re: #$%! Garmin updates

Postby liamw » Wed May 14, 2014 5:57 pm

My suspicion is that it is related to Garmin Express - my 510 was randomly deleting the settings (losing the bluetooth sync, the registration of the cadence and heart rate monitors, the bike profile and various display settings - I want KPH, not MPH damn it) whenever I started it after using it with the system that has Garmin Express installed.

I have since started using it with a laptop on which Garmin Express does not exist and I haven't had a problem since. I just rely on the phone connection to upload the rides to Garmin and use the computer connection to charge it and upload rides to Strava.

I haven't updated to the latest update (3.0 I think) because the update notes are... vague.
liamw
 
Posts: 37
Joined: Wed Mar 17, 2010 8:59 pm


Return to Garmin

Who is online

Users browsing this forum: No registered users



Popular Bike Shops
Torpedo 7 Torpedo7 AU
Ground Effect Ground Effect NZ
Chain Reaction Cycles CRC UK
Wiggle Wiggle UK
Ebay Ebay AU

“Bicycles BNA Twitter
“Bicycles BNA Facebook
“Google+ BNA Google+
“Bicycles BNA Newsletter

> FREE BNA Stickers
> BNA Cycling Kit