Edge 510 owners - impressions & gripes

Questions about purchasing bicycles and parts

Edge 510 owners - impressions & gripes

Postby Dr_Mutley » Mon Apr 08, 2013 8:16 pm

I just bought one as an upgrade to my 500, and so far have not been that impressed with it. I think it has great potential but so far the features seem quite buggy.

Here's a few of my gripes:

# Screen is difficult to see in any sort of sunlight - needs an anti-reflective coating to stop reflection.

# if u pause during a ride with the start/stop button the unit disconnects from all Ant+ devices. It will only re-pair with my HR strap and Quarq power meter if I turn the unit on and off

# battery life is very poor - if u have BT on u will only get 3 hours or so from the battery... Kind of makes Live Track a useless feature (albeit a feature of great potential)

# altimeter is terrible - my grade figure will bounce between -5% and 15% on a flat ride near the sea!!!

Anyone else have bugs/gripes or positive reports?

Hopefully a new firmware will be out soon to address some of the current issues....
Image
Dr_Mutley
 
Posts: 2050
Joined: Fri Jan 11, 2008 1:28 pm
Location: Flagstaff Hill, Adelaide SA 5159

by BNA » Mon Apr 08, 2013 9:34 pm

BNA
 

Re: Edge 510 owners - impressions & gripes

Postby r2160 » Mon Apr 08, 2013 9:34 pm

While I dont own one of the new ones, I do know that Garmin has an external power kit for them

http://www.chainreactioncycles.com/Mode ... pQodwzAAmQ

cheers
Glenn
-----------
"Pain is temporary. It may last a minute, or an hour, or a day, or a year, but eventually it will subside and something else will take its place. If I quit, however, it lasts forever" Lance Armstrong
r2160
 
Posts: 1062
Joined: Tue Jul 01, 2008 4:01 pm
Location: Bass Hill, NSW

Re: Edge 510 owners - impressions & gripes

Postby Fitzroy » Mon Apr 08, 2013 10:41 pm

Dr_Mutley wrote:# altimeter is terrible - my grade figure will bounce between -5% and 15% on a flat ride near the sea!!!


Agree with above.

# switching unit ON issue!

I haven't pinpointed it yet but if the unit is left off for a long time and then I try and turn it on it occasionally will not turn on. I press quickly, press and hold, press and hoooooold, then it all of a sudden starts. I even had to plug the USB cable into a USB charge point to get it to come alive. If the unit has started, is then turned off and then you come back to it, it starts with the slightest touch of the on switch. It appears to have some kind of 'super deep sleep' mode that takes ages to wake up from.

It is annoying becuase the usual time it is left ideal is overnight, you get up, get ready, start the Garmin, start the Garmin, start the Garmin, start the Garmin, START YOU F...... GARMIN, and run/Cavendish out the door!

If it continues it will be going back for replacement.
Fitzroy
 
Posts: 107
Joined: Sun May 31, 2009 9:38 pm

Re: Edge 510 owners - impressions & gripes

Postby jas0nt » Mon Apr 08, 2013 10:44 pm

Dr_Mutley wrote:# if u pause during a ride with the start/stop button the unit disconnects from all Ant+ devices. It will only re-pair with my HR strap and Quarq power meter if I turn the unit on and off


i have a Garmin 500 and i don't have this issue. seems like a bug.
jas0nt
 
Posts: 5
Joined: Tue Feb 05, 2013 11:20 am

Re: Edge 510 owners - impressions & gripes

Postby Dr_Mutley » Mon Apr 08, 2013 10:57 pm

jas0nt wrote:
Dr_Mutley wrote:# if u pause during a ride with the start/stop button the unit disconnects from all Ant+ devices. It will only re-pair with my HR strap and Quarq power meter if I turn the unit on and off


i have a Garmin 500 and i don't have this issue. seems like a bug.

It's a known 510 bug... The 500 works (reasonably) flawlessly for basic functions
Image
Dr_Mutley
 
Posts: 2050
Joined: Fri Jan 11, 2008 1:28 pm
Location: Flagstaff Hill, Adelaide SA 5159

Re: Edge 510 owners - impressions & gripes

Postby brett.hooker » Tue Apr 09, 2013 1:50 am

I purchased a 510 about three weeks ago and I am getting great battery life out of it. I did 7 hours elapsed on a ride on Sunday at it still had plenty of life left in it; and that was with livetracking enabled for the whole trip. I did a 2 hour 45 min ride tonight with the backlight on permanently and it only got down to 82% remaining, again with live track on.
Loving my Merida's and working towards adding a Pinarello to the stable... Go go go...
User avatar
brett.hooker
 
Posts: 384
Joined: Sun Sep 09, 2012 5:52 pm

Re: Edge 510 owners - impressions & gripes

Postby rolandgillead » Tue Apr 09, 2013 6:43 am

I haven't found too many bugs with mine yet but I haven't used it enough to have an informed opinion.

Having not owned a 500 before, my biggest gripe is the lack of information on how to use the bloody thing! I bought it without the heart strap and cadence sensor as I had these from my old Garmin HRM and I couldn't get the Edge to connect with them. The instructions that came with the device offered no assistance either. I ended up having to call the US support number who instructed me on how to enable both the cadence and HRM strap (they come disabled if you don't buy the bundle - WT??!).

And buggered if I know how to use any of the advanced features. I haven't found much in the way of online resources to really discover the power of the device and the settings aren't intuitive enough to know exactly what they do. I certainly don't want to bugger it up.

In saying that though it is a very powerful device. I just want to know how to use the bloody thing properly and to its full potential!
rolandgillead
 
Posts: 4
Joined: Wed Jan 02, 2013 12:45 pm

Re: Edge 510 owners - impressions & gripes

Postby BastardSheep » Tue Apr 09, 2013 8:25 am

How long does it usually take Garmin to iron out these kinds of bugs? Is there normally hardware updates within the same version number?

I ask because I've been eyeing off a Garmin 510 as my rewards if I actually keep up cycling this time (unlike past attempts to get back in to it). I currently replicate some (but not all) of its functions with a cheap $30 trip computer, cheap $30 HRM and my mobile in my pocket running endomondo/strava. I'd like to be able to leave the phone at home and clear up some handlebar space.

I'm very disappointed to see the altimeter is so inaccurate. That's one thing I was definitely hoping would be improved over the phone in the pocket.
n=1 | 2006 Learsport TR3240 Hardtail
User avatar
BastardSheep
 
Posts: 131
Joined: Tue Feb 26, 2013 6:54 pm
Location: Sydney.

Re: Edge 510 owners - impressions & gripes

Postby wombatK » Tue Apr 09, 2013 8:42 am

Dr_Mutley wrote:The 500 works (reasonably) flawlessly for basic functions

Except elevation is a complete work of fiction too. Unfortunately, the Bryton Rider's are
just as bad on that score.

Anything offering "barometric altitude" seems to just make it up as if feels like it, and any
correlation with true altitude is purely coincidental.

It's disappointing to hear that the 510 is not an evolutionary improvement, but rather
a degenerate offspring of its predecessor.

Cheers

WombatK
WombatK

Somebody has to do something, and it's just incredibly pathetic that it has to be us -Jerry Garcia
User avatar
wombatK
 
Posts: 5092
Joined: Thu Jul 10, 2008 9:08 pm
Location: Yagoona, AU

Re: Edge 510 owners - impressions & gripes

Postby MarkG » Tue Apr 09, 2013 11:43 am

Hi Dr M.

I've had an Edge 510 for several months, and I really like it over the 500.

I do like the slightly larger screen, and the GLONASS which picks up the satellites straight away.

The touch screen does a decent job too.

I don't like the interaction between the unit itself and Garmin Connect, it's a tad too 'buggy' in my instances.

I am waiting for wireless up load to Strava too.
Proudly "a hater of academics with helmet cams"
User avatar
MarkG
 
Posts: 2147
Joined: Mon Mar 28, 2011 1:02 pm
Location: Perth, Australia

Re: Edge 510 owners - impressions & gripes

Postby Fitzroy » Tue Apr 09, 2013 3:54 pm

rolandgillead wrote:I bought it without the heart strap and cadence sensor as I had these from my old Garmin HRM and I couldn't get the Edge to connect with them.


Can you post how you made this happen please. Even though my unit is being sent back as a 'lemon'.

Fitzroy wrote:# switching unit ON issue!
If it continues it will be going back for replacement.


Well it happened again this morning in an even more radical fashion! I was late for my run, as usual (dont ask, cyclist running, I know :roll: ) and I grabbed my 510 and pressed the button, it came alive! WOW I thought that was unusual. I glanced back at it and it looked like a TV that had lost all reception but in colour, it then switched off again. I then went through the usual, start the Garmin, start the Garmin, start the Garmin, START YOU F...... GARMIN! it eventually came on as I was half way down the street trying to run.

Having owned a 310XT previously that work flawlessly, this is such a let down. I think it was the fact I bought the bundle and left the sensor and HR in the box and tried to use my old stuff (and I thought the new unit 'might' be a dud). I got the speed/cadence to pair but not the HR. I still tempted fate by not unpacking it like a spoilt child and mounting everything.

Anyway, 2 weeks without a Garmin PITA.
Fitzroy
 
Posts: 107
Joined: Sun May 31, 2009 9:38 pm

Re: Edge 510 owners - impressions & gripes

Postby Dr_Mutley » Tue Apr 09, 2013 8:01 pm

Sounds like yr unit has a RMA issue.. I wouldn't persevere with it..,

I bought a bare unit, and I must admit it took a few reboots, and 15mins of continuous searching for the unit to pair with my old, standard HR strap from my 500. Pairing with my powermeter took 2 seconds however...
Image
Dr_Mutley
 
Posts: 2050
Joined: Fri Jan 11, 2008 1:28 pm
Location: Flagstaff Hill, Adelaide SA 5159

Re: Edge 510 owners - impressions & gripes

Postby Dr_Mutley » Tue Apr 09, 2013 8:04 pm

brett.hooker wrote:I purchased a 510 about three weeks ago and I am getting great battery life out of it. I did 7 hours elapsed on a ride on Sunday at it still had plenty of life left in it; and that was with livetracking enabled for the whole trip. I did a 2 hour 45 min ride tonight with the backlight on permanently and it only got down to 82% remaining, again with live track on.



Today I started with 100% charge... 2hr20min ride, 1hr20min with LiveTrack on, back light on 75% with night time screen (inverted colors) 50% charge left on completion

Image

Image
Image
Dr_Mutley
 
Posts: 2050
Joined: Fri Jan 11, 2008 1:28 pm
Location: Flagstaff Hill, Adelaide SA 5159

Re: Edge 510 owners - impressions & gripes

Postby brett.hooker » Tue Apr 09, 2013 9:27 pm

Dr_Mutley wrote:Today I started with 100% charge... 2hr20min ride, 1hr20min with LiveTrack on, back light on 75% with night time screen (inverted colors) 50% charge left on completion

Image

Image


I see the problem... You ride twice as fast as me which would have drawn more battery power as it had to keep up to date with all your movement...

:-)

Seriously though; is there a frequency setting for live updates? Mine is updating every sixty seconds.
Loving my Merida's and working towards adding a Pinarello to the stable... Go go go...
User avatar
brett.hooker
 
Posts: 384
Joined: Sun Sep 09, 2012 5:52 pm

Re: Edge 510 owners - impressions & gripes

Postby Dr_Mutley » Tue Apr 09, 2013 9:44 pm

brett.hooker wrote:
Seriously though; is there a frequency setting for live updates? Mine is updating every sixty seconds.


Not sure... I haven't come across that setting, so mine would be on whatever the default it...

Anyone else prefer the inverted (night) screen during the day? I really have trouble seeing the day screen due to sun glare/reflection off the screen...
Image
Dr_Mutley
 
Posts: 2050
Joined: Fri Jan 11, 2008 1:28 pm
Location: Flagstaff Hill, Adelaide SA 5159

Re: Edge 510 owners - impressions & gripes

Postby Dr_Mutley » Tue Apr 09, 2013 9:51 pm

I just noticed on live tracking than my average speed to my coffee stop was 34.13km/hr where on my garmin 510 it was actually 36.3km/hr...

Mid ride I stopped for 5 - 10mins for a nature break and to fill up my bottles... Seems the live track must calculate avg speed by elapsed time, not moving time?

Image
Image
Dr_Mutley
 
Posts: 2050
Joined: Fri Jan 11, 2008 1:28 pm
Location: Flagstaff Hill, Adelaide SA 5159

Re: Edge 510 owners - impressions & gripes

Postby ithier10 » Wed Apr 24, 2013 4:06 pm

Hi all, I bought a 510 exactly one week ago, to use with my brand new Quarq Riken power meter. I have been on 7 rides and have had nothing but problems.

Briefly they involve:

1. complete data dropouts for 1-2 minutes (during my 1 hour ride this morning there were 8 drop outs!) When you analyse the data in WKO+ or Garmin Connect large sections are missing. Try completing a 20min FTP test with 2 minutes of power wattage missing.
2. the unit powers off during a ride (this happened twice this morning), and you have to restart the device whilst riding, it keeps the ride duration going.
3. cadence drops to 14 or 38 when I'm constant at 90rpm (tested using polar and wahoo gear at the same time)

There are known issues with the 510 ( https://forums.garmin.com/archive/index ... 34165.html )

I contacted Garmin, Quarq and WKO+. Garmin suggested doing a software update. Gee I wouldn't have thought of that one! Quarq suggested upgrading the firmware, again a lackluster reply. The guy from TrainingPeaks WKO+ mentioned many of their staff are using the 510 and Quarq and all having issues. He mentioned there is a known issue and should be resolved in the V2.4 update that is in the pipeline.

The concern I have is how long will this update be ready? Its pretty poor when the issues chatter on Garmins own site started 2nd March 2013, and yet there is no statement or solution provided by Garmin!

Thankfully I brought the issues concern to the attention of my retailer before purchasing, meaning I can get a full refund on the unit, but I actually like the potential of the unit, so am stuck waiting for the upgrade and dealing with the dropouts.

Anyone have any suggestions on better units?
ithier10
 
Posts: 1
Joined: Fri Jul 13, 2012 11:05 pm

Re: Edge 510 owners - impressions & gripes

Postby Dr_Mutley » Wed Apr 24, 2013 11:36 pm

Go back to a edge 500 for awhile or u will pull yr hair out...

Having said that, besides my 510 un-pairing from ANT+ (HR/Quarq) devices after a period of inactivity, I've had no other issues with my 510, and it's interaction with my Quarq....
Image
Dr_Mutley
 
Posts: 2050
Joined: Fri Jan 11, 2008 1:28 pm
Location: Flagstaff Hill, Adelaide SA 5159

Re: Edge 510 owners - impressions & gripes

Postby whenin_rome » Thu May 02, 2013 8:29 pm

A few of us went on a ride and ascented 1,000m recently but a guy with a new Garmin apparently climbed 5000m !
His ambient temperature reading was consistently out from our (older) Garmins as well
I am sure these issues will all get ironed out eventually but for now Im happy I bought an old one !
Do as the Romans do!
User avatar
whenin_rome
 
Posts: 38
Joined: Tue Feb 07, 2012 10:02 am

Re: Edge 510 owners - impressions & gripes

Postby Jesmol » Thu May 02, 2013 8:43 pm

All, note they've just released a new firmware which supposedly addresses many of the issues with the original "beta" releases.
Jesmol
 
Posts: 247
Joined: Tue Feb 07, 2012 2:48 pm

Re: Edge 510 owners - impressions & gripes

Postby macca33 » Thu May 02, 2013 8:51 pm

Bit disgraceful really - did they not perform proper beta testing? Most (if not all) of the issues mentioned here are hardly out of the ballpark as far as predictability goes, so why are they occurring?

Good luck with them - I hope my 500 keeps going strong for a long time yet!

cheers
'dale CAAD10 - Ultegra6700 | CAAD10 Team - DA7800

Image
macca33
 
Posts: 665
Joined: Wed Sep 26, 2012 11:05 pm
Location: West Gippy

Re: Edge 510 owners - impressions & gripes

Postby brett.hooker » Thu May 02, 2013 8:56 pm

My 510 is still going strong with zero issues. It gets used every day, on two different bikes, with live track and auto upload via my iPhone...

Very very happy with it...
Loving my Merida's and working towards adding a Pinarello to the stable... Go go go...
User avatar
brett.hooker
 
Posts: 384
Joined: Sun Sep 09, 2012 5:52 pm

Re: Edge 510 owners - impressions & gripes

Postby Dr_Mutley » Fri May 03, 2013 2:09 am

A firmware revision is out, so those having issues, fire up webupdater, and load up v2.50


http://www8.garmin.com/support/download ... sp?id=6049

Change History
Changes made from version 2.30 to 2.50:
Improved power data recording.
Fixed issue causing the device to not reconnect to ANT sensors after losing connection.
Added support for heart rate graph data field.
Added Training Plans support.
Improved elevation recording.
Improved elevation page visibility.
Fixed 30 second vertical speed average data field.
Fixed issue with phone connections.
Improved compass page.
Updated power zone defaults and added functionality to reset to default values.
Restricted a software update from taking place if the battery is below 10% capacity.
Added press and hold shortcuts to bike and activity profiles from the home screen.
Added weather icon to Connections page.
Made numerous UI improvements.
Updated translations.
Image
Dr_Mutley
 
Posts: 2050
Joined: Fri Jan 11, 2008 1:28 pm
Location: Flagstaff Hill, Adelaide SA 5159

Re: Edge 510 owners - impressions & gripes

Postby seddo » Fri May 03, 2013 7:33 am

I purchased a 510 a couple of months ago, have never owned a garmin before,more than happy with it - good battery life, great satellite connection, decent size screen for my failing eyes and no magnets.The only issue is blue toothing with my Samsung Galaxy S2 it seems to be very hit and miss.

cheers
Seddo
Image
seddo
 
Posts: 347
Joined: Sun Feb 25, 2007 8:58 pm
Location: ACT

Re: Edge 510 owners - impressions & gripes

Postby Dr_Mutley » Fri May 03, 2013 10:35 am

seddo wrote:I purchased a 510 a couple of months ago, have never owned a garmin before,more than happy with it - good battery life, great satellite connection, decent size screen for my failing eyes and no magnets.The only issue is blue toothing with my Samsung Galaxy S2 it seems to be very hit and miss.

cheers
Seddo


Your connection issues might be fixed now given the changelog of v2.50
Image
Dr_Mutley
 
Posts: 2050
Joined: Fri Jan 11, 2008 1:28 pm
Location: Flagstaff Hill, Adelaide SA 5159

Next

Return to Buying a bike / parts

Who is online

Users browsing this forum: No registered users



Support BNA
Click for online shops
Torpedo 7 Torpedo7 AU
Ground Effect Ground Effect NZ
Chain Reaction Cycles CRC UK
Wiggle Wiggle UK
Cycling Express Cycling Express
Ebay Ebay AU
ProBikeKit ProBikeKit UK
Evans Cycles Evans Cycles UK
JensonUSA Jenson USA
JensonUSA Competitive Cyclist