Error Posting on BNA Forums + Offline

News from Bicycles Network Australia and the Australian Cycling Forums

Error Posting on BNA Forums + Offline

Postby AUbicycles » Tue Oct 13, 2009 10:19 pm

Hello,
My inbox is full of emails regarding the problem posting on the BNA Forums. Thankyou Here is what I know about the outage and problems posting.

Forum offline at 12:30 GMT + 8 SQL ERROR [ mysql4 ] Too many connections [1040]
From about 4:50pm I started receiving emails and this problem has been fixed at 11:20pm - 6 hours 30 minutes posting caused an error.

I did get this email from the host:
Digital Pacific has discovered a major fault in one of the UPS units and will be performing an emergency power operation in DC tomorrow morning (October 14th 2009) between 6:00am and 6:30am.


I have no idea whether there is any connection however what has happened is that first the forum (and entire site) was offline due to too many connections. This is not the first time and has been highlighted a few times however I can't track this further and the host doesn't know what is causing it. catch 22. The second issue is that somehow the database has become corrupt (hence error messages when posting). I was able to run a repair and fix it - and feel that the error has a connection with either or both of the afore mentioned problems.

Sorry it was not possible to resolve sooner - I wasn't online.
I am now looking into solutions so that these problems don't plague us.


Christopher (Admin)
User avatar
AUbicycles
Site Admin
Site Admin
 
Posts: 9069
Joined: Tue Aug 23, 2005 2:14 am
Location: Sydney

by BNA » Tue Oct 13, 2009 10:20 pm

BNA
 

Re: Error Posting

Postby provoked » Tue Oct 13, 2009 10:20 pm

Wooo - test response!
Giant TCR Alliance 2 '09

The mind is its own place, and in itself, can make heaven of Hell, and a hell of Heaven. - John Milton
User avatar
provoked
 
Posts: 1110
Joined: Fri Nov 07, 2008 9:01 pm
Location: Mebourne - North

Re: Error Posting

Postby provoked » Tue Oct 13, 2009 10:27 pm

However - it's eerily quiet again?

Edit - OO, thought it was broken again, guess not!
Giant TCR Alliance 2 '09

The mind is its own place, and in itself, can make heaven of Hell, and a hell of Heaven. - John Milton
User avatar
provoked
 
Posts: 1110
Joined: Fri Nov 07, 2008 9:01 pm
Location: Mebourne - North

Re: Error Posting on BNA Forums + Offline

Postby provoked » Tue Oct 13, 2009 10:36 pm

Christopher, just an FYI, I was able to access and view the forums the entire time, just couldn't post anything (with the error message you have mentioned).
Giant TCR Alliance 2 '09

The mind is its own place, and in itself, can make heaven of Hell, and a hell of Heaven. - John Milton
User avatar
provoked
 
Posts: 1110
Joined: Fri Nov 07, 2008 9:01 pm
Location: Mebourne - North

Re: Error Posting on BNA Forums + Offline

Postby hartleymartin » Tue Oct 13, 2009 11:06 pm

Had exactly the same problem.
Martin Christopher Hartley

http://raleightwenty.webs.com - the top web resource for the Raleigh Twenty
http://madmartysblog.blogspot.com - my cycling adventures
User avatar
hartleymartin
 
Posts: 5069
Joined: Thu Feb 19, 2009 5:56 pm
Location: Old Toongabbie, NSW

Re: Error Posting on BNA Forums + Offline

Postby Mulger bill » Tue Oct 13, 2009 11:18 pm

Same here, tho it did let me post PMs. Weird...

Shaun
...whatever the road rules, self-preservation is the absolute priority for a cyclist when mixing it with motorised traffic.
London Boy 29/12/2011
User avatar
Mulger bill
Super Mod
Super Mod
 
Posts: 25681
Joined: Sun Sep 24, 2006 2:41 pm
Location: Sunbury Vic

Re: Error Posting on BNA Forums + Offline

Postby AUbicycles » Wed Oct 14, 2009 12:42 am

yes... me too.

There was an error in one database - which stores the post. I don't know why or how, just that posting was not possible - though PMs were working.
The other error (forum offline) was temporary and was for about 10 minutes - and would have affected the entire site (site + forum).

Cheers
Christopher
User avatar
AUbicycles
Site Admin
Site Admin
 
Posts: 9069
Joined: Tue Aug 23, 2005 2:14 am
Location: Sydney

Re: Error Posting on BNA Forums + Offline

Postby steambao » Wed Oct 14, 2009 11:31 am

Well the error was related to a duplicate primary key, so it could have been something along the lines of the MYSQL server auto_increment wasn't working for the post table. As well all know you can't have duplicate primary keys in the one table :mrgreen:
Image
User avatar
steambao
 
Posts: 188
Joined: Mon Oct 12, 2009 12:45 am
Location: Banyule, N.E. Melbourne

Re: Error Posting on BNA Forums + Offline

Postby AUbicycles » Thu Oct 15, 2009 7:58 am

Yes... and I am glad that the internet gave me the answers on how to fix it... thank you internet.

Host suggested that their power loss was the probably cause - main topic now is the "max connections" and working out why the site keeps on going offline.
User avatar
AUbicycles
Site Admin
Site Admin
 
Posts: 9069
Joined: Tue Aug 23, 2005 2:14 am
Location: Sydney


Return to Info / announcements

Who is online

Users browsing this forum: No registered users



Popular Bike Shops
Torpedo 7 Torpedo7 AU
Ground Effect Ground Effect NZ
Chain Reaction Cycles CRC UK
Wiggle Wiggle UK
Ebay Ebay AU

“Bicycles BNA Twitter
“Bicycles BNA Facebook
“Google+ BNA Google+
“Bicycles BNA Newsletter

> FREE BNA Stickers
> BNA Cycling Kit