removing cranks, help please.

User avatar
janus77
Posts: 803
Joined: Mon Aug 27, 2007 3:09 pm

removing cranks, help please.

Postby janus77 » Sat Jun 14, 2008 9:30 pm

I'm having trouble removing the cranks from the BB.. not sure why, I'm using the crank removing tool, where after removing the bolts, i screw the first part into the thread, then screw the bit that pushes through the middle to lever the crank arm off the BB.

It's not working though, i tighten it and it just sticks, I can't get the arm to budge at all.

Any advice?

User avatar
Mulger bill
Super Mod
Super Mod
Posts: 28265
Joined: Sun Sep 24, 2006 2:41 pm
Location: Sunbury Vic

Postby Mulger bill » Sat Jun 14, 2008 9:39 pm

At a guess Janus, square taper BB and a fairly late model crankpuller?

If so, the bit on the end of the "pushy" bit that contacts the crank spindle prolly has some sort of oversize adaptor cap on it to fit ISIS and octalink spindles which are a bit fatter. Have a look, see if you can get it off.

Shaun
...whatever the road rules, self-preservation is the absolute priority for a cyclist when mixing it with motorised traffic.
London Boy 29/12/2011

User avatar
janus77
Posts: 803
Joined: Mon Aug 27, 2007 3:09 pm

Postby janus77 » Sat Jun 14, 2008 11:47 pm

thanks mate, ended up just needing a bit more elbow grease than I'd anticipated.

Current probelm is I accidentally remove the link pin completely.. painful trying to get it back in.

User avatar
janus77
Posts: 803
Joined: Mon Aug 27, 2007 3:09 pm

Postby janus77 » Sun Jun 15, 2008 12:33 pm

Got the BB out, cleaned it up (sealed bearing type, so not much to be done, bit of lube around the bits..), put everything back together.

I stuffed up the chain!! damnit, I removed one of the link pins completely by mistake. Ended up dabbing a bit of grease around the link hole so that the pin would sit in place on it's own while I put it in the chain breaker, anyway, I might have put the outside part of the sleeve in the breaker without slipping the other link in to try to get it connected. Think I've bent that particular chain link, because now that I've got it back together it sticks, the link is all locked up.

What's my best option here? Remove that link and get a replacment link to put in (Great, will have the same probelm getting the link pin back in), or go for a whole new chain? Or finally undo it and try to bend it back out a bit so it moves properly?

Cheers.

User avatar
il padrone
Posts: 22729
Joined: Mon Apr 07, 2008 11:57 pm
Location: Heading for home.

Postby il padrone » Sun Jun 15, 2008 12:55 pm

Is this a Shimano chain?

Because they recommend rejoining the chain with their special link pin (a longer one, with a 'pencil' tip that you push through then snap the end off). If you just push the existing links back in you damage the special edges on them, and eventually they'll come out - broken chain!!

The little pins are ridiculously expensive, something like $2.50 for one. And you need a new one each time you break the chain to clean it. A much better option is to spend a bit more and get a Connex or Sram joining link. They're re-usable and make it much quicker to break your chain for cleaning - no tools needed. Phantom has these listed as MTB parts, but they're 9 spd so should be compatible with road 9 spd too, I believe.

Go ask about these at your LBS. Any decent shop will stock them.
Mandatory helmet law?
"An unjustified and unethical imposition on a healthy activity."

User avatar
janus77
Posts: 803
Joined: Mon Aug 27, 2007 3:09 pm

Postby janus77 » Sun Jun 15, 2008 1:01 pm

thanks, will have a look into it.

thomas_cho
Posts: 1186
Joined: Sat Jul 21, 2007 12:45 pm
Location: Canberra ACT

Postby thomas_cho » Sun Jun 15, 2008 1:13 pm

janus77 wrote:Got the BB out, cleaned it up (sealed bearing type, so not much to be done, bit of lube around the bits..), put everything back together.

I stuffed up the chain!! damnit, I removed one of the link pins completely by mistake. Ended up dabbing a bit of grease around the link hole so that the pin would sit in place on it's own while I put it in the chain breaker, anyway, I might have put the outside part of the sleeve in the breaker without slipping the other link in to try to get it connected. Think I've bent that particular chain link, because now that I've got it back together it sticks, the link is all locked up.

What's my best option here? Remove that link and get a replacment link to put in (Great, will have the same probelm getting the link pin back in), or go for a whole new chain? Or finally undo it and try to bend it back out a bit so it moves properly?

Cheers.


Okay this is not recommended by the manufacturers, but this is what I did to an 8 spd chain. I had to shorten the chain, and while I did not push the whole pin out, I did have the issue about the link getting locked up.

Firstly visually inspect the pin, and compare it to the neighbouring pin to see if you have pushed it too far, or not enuf. Then flex the chain, ie bend it sideways, to and fro to "loosen" the link. I think this helps the pin to seat properly.

I used the chain in a single speed set up, and on certain ocassions had to stomp hard on the pedals. The chain has held up.

But considering that you did push the pin all the way through, I suggest discarding the join, and using a quick link. Having the chain break on you on a ride is probably not worth saving that $10-20.

User avatar
janus77
Posts: 803
Joined: Mon Aug 27, 2007 3:09 pm

Postby janus77 » Sun Jun 15, 2008 2:53 pm

it's not as rewarding working on your bike when you can't take it out for a spin and see how it's running.. weather is gross

MountGower

Postby MountGower » Sun Jun 15, 2008 8:28 pm

Just soap up before you leave, Janus. Then it will be worth it.

User avatar
janus77
Posts: 803
Joined: Mon Aug 27, 2007 3:09 pm

Postby janus77 » Mon Jun 16, 2008 9:54 am

Am i correct in thinking your idea of personal hygeine is covering yourself in soap and riding up and down your street naked in the rain?

Who is online

Users browsing this forum: Google Feedfetcher