Shimano Altus c20 rear shifter issue - please help me thanks

Workshop tales, trials and disasters.
Maintenance tips, techniques and myths.
Technical discussion, description and outright lies

Shimano Altus c20 rear shifter issue - please help me thanks

Postby cyc715t » Sat Apr 13, 2013 1:27 pm

Hi, how is everyone going?

I've run into a problem here...

I got a shimano altus c20 rear shifter that doesn't really want to engage properly and change gear. You have to flick the shifter many, many times before it starts to engage and change gear... once it does engage.. it works and goes up and then down but after it goes down to the smallest cog, it then does the same thing where you keep flicking the lever and it won't engage until about 20 or so flicks if you are lucky before it decides to respond and change gears to the bigger cogs.

The cable isn't slack or anything on the smallest cog and the screws are adjusted fine. What do you think the problem is and how can I fix it please?

Thanks in advance!
cyc715t
 
Posts: 91
Joined: Sat Sep 17, 2011 9:16 pm

by BNA » Sun Apr 14, 2013 3:29 pm

BNA
 

Re: Shimano Altus c20 rear shifter issue - please help me th

Postby high_tea » Sun Apr 14, 2013 3:29 pm

cyc715t wrote:Hi, how is everyone going?

I've run into a problem here...

I got a shimano altus c20 rear shifter that doesn't really want to engage properly and change gear. You have to flick the shifter many, many times before it starts to engage and change gear... once it does engage.. it works and goes up and then down but after it goes down to the smallest cog, it then does the same thing where you keep flicking the lever and it won't engage until about 20 or so flicks if you are lucky before it decides to respond and change gears to the bigger cogs.

The cable isn't slack or anything on the smallest cog and the screws are adjusted fine. What do you think the problem is and how can I fix it please?

Thanks in advance!


I'd be thinking about changing the cable.
high_tea
 
Posts: 1269
Joined: Thu Apr 29, 2010 8:10 pm

Re: Shimano Altus c20 rear shifter issue - please help me th

Postby cyc715t » Mon Apr 15, 2013 7:25 am

what happens if it is not the cable please?
cyc715t
 
Posts: 91
Joined: Sat Sep 17, 2011 9:16 pm

Re: Shimano Altus c20 rear shifter issue - please help me th

Postby high_tea » Mon Apr 15, 2013 12:10 pm

The next most likely culprit, do you mean? The cable housing.
high_tea
 
Posts: 1269
Joined: Thu Apr 29, 2010 8:10 pm

Re: Shimano Altus c20 rear shifter issue - please help me th

Postby simonn » Mon Apr 15, 2013 12:48 pm

cyc715t wrote:You have to flick the shifter many, many times before it starts to engage and change gear... once it does engage.. it works and goes up and then down but after it goes down to the smallest cog, it then does the same thing where you keep flicking the lever and it won't engage until about 20 or so flicks if you are lucky before it decides to respond and change gears to the bigger cogs.


The bureaucratic shift. You need to submit a proposal to change gear.

Dirty/frayed/corroded inner and/or outer cables

Have you been riding in mud/rain? Change your cables.
Image
User avatar
simonn
 
Posts: 3634
Joined: Thu Jan 31, 2008 10:46 am
Location: Sydney

Re: Shimano Altus c20 rear shifter issue - please help me th

Postby cyc715t » Mon Apr 15, 2013 5:24 pm

I didn't think it was the cables etc as it does change gear. The problem is I have to flick the lever about 20 times before it decides to engage and change gear. Once it does, it changes up and down each time but once it goes back to the smaller cog, the same thing happens again..where I need to flick the lever 20 or so times...
cyc715t
 
Posts: 91
Joined: Sat Sep 17, 2011 9:16 pm

Re: Shimano Altus c20 rear shifter issue - please help me th

Postby kb » Mon Apr 15, 2013 5:39 pm

It's possible your chain is too long and the pulley is getting caught on the rear sprockets when in your highest gear.

Still think it sounds like cables though.
Image
User avatar
kb
 
Posts: 933
Joined: Sun Nov 13, 2011 2:22 pm

Re: Shimano Altus c20 rear shifter issue - please help me th

Postby fooch » Tue Apr 16, 2013 10:08 am

It might also be the shifters. Are they the ones with two levers, i.e. Rapidfire? apart from what has been suggested above, all of which are good suggestions, you can also spray some WD40 or similar light spray lube into the shifter itself to dislodge the gunk buildup internally. This usually improves shifting.
Piled Higher & Deeper
fooch
 
Posts: 261
Joined: Sun Mar 01, 2009 6:53 pm
Location: Near Kew, Melb

Re: Shimano Altus c20 rear shifter issue - please help me th

Postby Dan » Tue Apr 16, 2013 10:45 am

5 internet dollars says its the cable. Or, you could ask for advice, then ignore it. That also costs five internet dollars.
User avatar
Dan
 
Posts: 3289
Joined: Fri Oct 16, 2009 12:32 pm
Location: Vegas, baby


Return to The Shed

Who is online

Users browsing this forum: Bing [Bot], Newcastle Dave



Popular Bike Shops
Torpedo 7 Torpedo7 AU
Ground Effect Ground Effect NZ
Chain Reaction Cycles CRC UK
Wiggle Wiggle UK
Ebay Ebay AU

“Bicycles BNA Twitter
“Bicycles BNA Facebook
“Google+ BNA Google+
“Bicycles BNA Newsletter

> FREE BNA Stickers
> BNA Cycling Kit