Radbot - 500 v 1000?

Beating the system - the cycling commuting section

Radbot - 500 v 1000?

Postby misterhorsey » Mon Jun 24, 2013 10:35 am

Hello there.

Anyone have any experience of these lights?

I'm thinking of upgrading my rear light and was thinking of getting a 1000, but also concerned that it might be too bright. I'm commuting on roads and paths, and while I want to be seen I don't want to annoy or blind people behind me.

Is the 500 sufficient for visibility?

I was thinking one alternative is to buy 2x 500s. Mount one on the seat post and one on the rack. That way while I will have lights that are less bright, there will be two of them, which will build in some degree of redundancy should anything fail. Of course there's two sets of lights to take on or off and two sets of batteries to recharge, but that's not usually been too much of a hassle with my previous cateye rear light set up.

Partly interested in these lights due to decent reviews around the web as well as a discount voucher I need to use:

http://www.cellbikes.com.au/PDW-RADBOT- ... Best?ext=F

and the 500

http://www.cellbikes.com.au/PDW-Radbot-500-Rear-Light
misterhorsey
 
Posts: 413
Joined: Fri Apr 17, 2009 5:18 pm
Location: Northcote

by BNA » Mon Jun 24, 2013 11:13 am

BNA
 

Re: Radbot - 500 v 1000?

Postby macca33 » Mon Jun 24, 2013 11:13 am

I have the 1000 - on all of my bikes - and it is fantastic. It is very bright and the batteries (2 x AAA) last a number of hours - cannot specifically recall the time, but well over 30 hours of riding when using the weird flasher mode.

Only thing I've noticed is that road grime / muck can get into the o-ring of the on/off button, so it has to be cleaned periodically to avoid it becoming stuck.

cheers
Last edited by macca33 on Mon Jun 24, 2013 11:26 am, edited 1 time in total.
'dale CAAD10 Berzerker Ult6800 & CAAD10 Team Ult6800

Image
macca33
 
Posts: 825
Joined: Wed Sep 26, 2012 11:05 pm
Location: West Gippy

Re: Radbot - 500 v 1000?

Postby biker jk » Mon Jun 24, 2013 11:14 am

I have used the Radbot 1000. It's very bright but the battery life is poor. I averaged around 7-9hrs between recharges. As such, I now have a Cygolite Hotshot which is just as bright, has more light patterns (and adjustability) and runs for at least 40 hours (USB rechargeable which the Radbot isn't).
User avatar
biker jk
 
Posts: 2652
Joined: Tue Nov 17, 2009 5:18 pm
Location: Sydney

Re: Radbot - 500 v 1000?

Postby simonn » Mon Jun 24, 2013 12:09 pm

I've had three radbot 1000s for ~2-3 years. One died. It works until you hit a pothole then blinks dimly and feebly. If you take it apart and re-seat the batteries it works properly again... until the the next pothole. However, the problem appears to be with the circuitry, because if I swap around the part of the light with the battery holder the same problem occurs. Weird as!

Personally, I'd go one radbot and one fiberflare. Fiberflare is awesomely visible, very flexible as far as mounting goes and with ok battery life. Radbot is an adequate blinky with ok battery life, but also has a reflector which makes you legal (and audax compliant :)).

The thing I do not like about the usb lights is that if the battery dies I cannot simply replace it with a spare set that I can carry (which is cheaper than carrying a whole spare light) or buy at the next servo etc. Depends on circumstances of course, but this is handy for audax at least.

Anway, go the 1000 over the 500. More light is better (up to a point, but 1W is nowhere near that point).
Image
User avatar
simonn
 
Posts: 3597
Joined: Thu Jan 31, 2008 10:46 am
Location: Sydney

Re: Radbot - 500 v 1000?

Postby DoogleDave » Mon Jun 24, 2013 12:24 pm

[quote="biker jk"]As such, I now have a Cygolite Hotshot which is just as bright....quote]

+1 for the Cygolite Hotshot. I have one and love it.

I always think it's going to run out mid-ride because it just keeps going but I am yet to have it run out of battery...and recharging is easy and painless.

Dave
2012 Felt F75 | 105 | ProLite Braccianos | GP4000S
Image
User avatar
DoogleDave
 
Posts: 519
Joined: Mon Mar 12, 2012 6:56 pm
Location: Taylors Hill, Victoria

Re: Radbot - 500 v 1000?

Postby mikedufty » Mon Jun 24, 2013 1:54 pm

I bought the 500 thinking I was getting a 1000 (didn't realise there were two models). I've been perfectly happy with the 500, lasts several months of daily commuting on a set of batteries, is nice and bright, and comes with a reflector and rack mount. I have a second taillight of a different brand. I think two is a very good idea, especially as I find they tend to turn themselves off after 15 minutes when the batteries get flat, so you could find you've done half a ride with no taillight if you don't have two. Too important to depend on just one.
User avatar
mikedufty
 
Posts: 630
Joined: Fri Mar 27, 2009 4:52 pm
Location: Western Australia, Bull Creek

Re: Radbot - 500 v 1000?

Postby misterhorsey » Mon Jun 24, 2013 2:52 pm

thanks guys.

i'm not sure if its misplaced, but I have a preference for stand alone rechargeable NiHM batteries. Cheap and easy to maintain if you have a little supply of them and a decent charger, as I do. Plus the radbot has a rack mount already with it, which is edging that one ahead for now over the Cygolite.

Unfortunately lights are consumables to an extent. We expect a lot from them but they also go through a lot. Relatively cheap tho.

(I know you can get a rackmount for another $10 or so for the cygolite but that's already half a radbot 500)

edit: spelling errors, typos etc
misterhorsey
 
Posts: 413
Joined: Fri Apr 17, 2009 5:18 pm
Location: Northcote

Re: Radbot - 500 v 1000?

Postby TedDancin » Mon Jun 24, 2013 4:29 pm

I bought the Radbot 500 a few months ago, and due to some dodgy attachment on my part, lost it on a ride to work (metal bracket sheared off due to metal fatigue). Had the option of buying either the 500 or 1000 for the same price, and I bought the 500 again. I figure that the 500 is bright enough for me to be seen from behind, and the batteries last twice as long (reportedly ~75 hours on alkalines). Also have a much stronger bracket this time.
TedDancin
 
Posts: 122
Joined: Fri May 04, 2012 9:51 am
Location: Sydney, NSW

Re: Radbot - 500 v 1000?

Postby Mulger bill » Mon Jun 24, 2013 8:25 pm

One of each, plus a redzone 4 on the commuter. They work and work well, no need to replace.

Simonn, check out the electrical connections between the two halves, a little oxydisation is not unknown.

Shaun
...whatever the road rules, self-preservation is the absolute priority for a cyclist when mixing it with motorised traffic.
London Boy 29/12/2011
User avatar
Mulger bill
Super Mod
Super Mod
 
Posts: 25772
Joined: Sun Sep 24, 2006 2:41 pm
Location: Sunbury Vic

Re: Radbot - 500 v 1000?

Postby warthog1 » Tue Jun 25, 2013 10:29 am

My radbot 1000 has started playing up, only runs for a few minutes before switching itself off.
It is bright but battery life is poor and a PITA to pull apart and charge every 2 or 3 days. Get a USB rechargeable light. The cygolight sounds good.
User avatar
warthog1
 
Posts: 2823
Joined: Wed Jul 25, 2012 4:40 pm

Re: Radbot - 500 v 1000?

Postby grasshopper » Tue Jun 25, 2013 12:25 pm

I have the 1000 and used to get about 25 hours out of non-rechargeables. But I would always run a secondary light with it, because when the batteries go it just dies; it doesn't fade. Not sure if the newer ones are different; this was one of the first batch. And +1 for the Fibre Flare for commuting too, although the first one didn't work and was replaced.
User avatar
grasshopper
 
Posts: 331
Joined: Mon Nov 02, 2009 7:04 pm
Location: Melbourne

Re: Radbot - 500 v 1000?

Postby misterhorsey » Tue Jun 25, 2013 2:49 pm

I went for the Radbot 1000 and will be running it with the cateye I have on at the moment. Radbot on pannier rack, cat eye on seat post.

Of course, I forgot what warthog1 and others said about battery life when I confirmed the order - doh! At least it will make me use the flat head screwdriver in the mini tool I bought as well. Woops, just checked that the mini tool doesn't have a flat head. doh x 2!

I'm intriuged by the fibre flare but I run pannier bags so my seat stays will be obsured. The reflectives on the back of the ortiliebs are very good from my experience, and combined with two relatively bright flashers I will at least be a cut above the median commuter in visibility me thinks.
misterhorsey
 
Posts: 413
Joined: Fri Apr 17, 2009 5:18 pm
Location: Northcote

Re: Radbot - 500 v 1000?

Postby biker jk » Tue Jun 25, 2013 2:52 pm

misterhorsey wrote:I went for the Radbot 1000 and will be running it with the cateye I have on at the moment. Radbot on pannier rack, cat eye on seat post.

Of course, I forgot what warthog1 and others said about battery life when I confirmed the order - doh! At least it will make me use the flat head screwdriver in the mini tool I bought as well. Woops, just checked that the mini tool doesn't have a flat head. doh x 2!

I'm intriuged by the fibre flare but I run pannier bags so my seat stays will be obsured. The reflectives on the back of the ortiliebs are very good from my experience, and combined with two relatively bright flashers I will at least be a cut above the median commuter in visibility me thinks.


The Radbot requires a Philips head screwdriver to remove the batteries.
User avatar
biker jk
 
Posts: 2652
Joined: Tue Nov 17, 2009 5:18 pm
Location: Sydney

Re: Radbot - 500 v 1000?

Postby misterhorsey » Tue Jun 25, 2013 3:10 pm

biker jk wrote:
misterhorsey wrote:I went for the Radbot 1000 and will be running it with the cateye I have on at the moment. Radbot on pannier rack, cat eye on seat post.

Of course, I forgot what warthog1 and others said about battery life when I confirmed the order - doh! At least it will make me use the flat head screwdriver in the mini tool I bought as well. Woops, just checked that the mini tool doesn't have a flat head. doh x 2!

I'm intriuged by the fibre flare but I run pannier bags so my seat stays will be obsured. The reflectives on the back of the ortiliebs are very good from my experience, and combined with two relatively bright flashers I will at least be a cut above the median commuter in visibility me thinks.


The Radbot requires a Philips head screwdriver to remove the batteries.


awesome. I thought I read a review that it required a flat head. wonderful!
misterhorsey
 
Posts: 413
Joined: Fri Apr 17, 2009 5:18 pm
Location: Northcote

Re: Radbot - 500 v 1000?

Postby Philipthelam » Tue Jun 25, 2013 5:48 pm

It's very good for people (like me) who use a rack as they provide a mount for it. With most other brands you have to buy a mount, which is annoying when you pay $20 for a light and then you still have to pay another $10 to buy the rack mount.
Philipthelam
 
Posts: 323
Joined: Fri Jul 13, 2012 2:10 pm

Re: Radbot - 500 v 1000?

Postby grasshopper » Tue Jun 25, 2013 5:59 pm

misterhorsey wrote:I'm intriuged by the fibre flare but I run pannier bags so my seat stays will be obsured. The reflectives on the back of the ortiliebs are very good from my experience, and combined with two relatively bright flashers I will at least be a cut above the median commuter in visibility me thinks.

Sounds good. I seem to get very good battery life from the Fibre Flare although I haven't tracked it. I just clip it across the top of the Ortliebs at night so I look a little wider on the commuter, but put it on the seat stay on the roadie.
User avatar
grasshopper
 
Posts: 331
Joined: Mon Nov 02, 2009 7:04 pm
Location: Melbourne

Re: Radbot - 500 v 1000?

Postby misterhorsey » Mon Jul 01, 2013 10:27 am

Bought and installed it, very happy with its operation so far.

I did a quick vox pop while waiting at the traffic lights, asked the motorist beside me and the cyclist behind me whether the light was too bright and they advised me that it was just fine. 100% approval from a sample size of 2.

Hopefully the construction will hold up and recharging won't be too annoying.
misterhorsey
 
Posts: 413
Joined: Fri Apr 17, 2009 5:18 pm
Location: Northcote

Re: Radbot - 500 v 1000?

Postby misterhorsey » Thu Aug 08, 2013 10:31 am

So after 38 days of steady use, through many a rainy night, my radbot has started to die. Which is rather disappointing.

It will operate for about a minute before switching itself off.

The good news is that it ran for 38 nights of commuting on one set of batteries. Although these are not the longest commutes, and battery life isn't terribly important if the light doesn't work.

I've opened up and changed batteries, but will have another look to see if there are any battery seating issues.
misterhorsey
 
Posts: 413
Joined: Fri Apr 17, 2009 5:18 pm
Location: Northcote

Re: Radbot - 500 v 1000?

Postby InTheWoods » Thu Aug 08, 2013 1:52 pm

Hmm they aren't very water proof. I often have to open mine up to dry out after it rains. Also check where the connectors from the battery side touch metal pads on the circuit/led side.
Image
User avatar
InTheWoods
 
Posts: 1440
Joined: Sun Jul 31, 2011 2:34 pm
Location: Brisbane

Re: Radbot - 500 v 1000?

Postby Comedian » Thu Aug 08, 2013 2:14 pm

I've got four of them. A while back one started randomly switching off while riding.

Recently a second one has started doing the same. I find it very concerning when you finish a ride to find your light switched off at some point. Not good. In my experience once this starts happening it can't be fixed. I'm not sure what the cause is - but if they were designed to default to on after and break in power I don't think the problem would be as bad.

In fairness though... These were both high mileage lights so I don't feel too dudded.

So - I've switched to a moon comet. They need to be charged every few days. However they are tiny and light. Plus they have a stun the motorist mode plus a more sedate solid mode so you don't annoy your group riding buddies.

I believe cell have them for $35 at the moment.
Once you can climb hills on a bike it's all downhill. :mrgreen:

Hopefully I'll know what that's like..... one day. :shock: :lol:

Image
User avatar
Comedian
 
Posts: 4412
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Re: Radbot - 500 v 1000?

Postby misterhorsey » Thu Aug 08, 2013 4:06 pm

My light still turns on, until the bike moves (or you simulate movement by shaking it), after which a contact point internally seems to skip a beat and then it goes dark.

On a side note, I bought this light online from cell. I rang their new fitzroy store to ask if I could drop by to discuss replacement/repair, and was advised that I could but it would be pointless as they are separate stores from online. I asked him if it was a franchise and he said that the name was franchised but not the store itself.

Rang cell who told me to send it back and they'll inspect and send me a new one. I asked if they would send me a different model, given the bad experience of the radbot, and they told me to write a note and they could discuss it (I'll pay the difference).

Hmmm. It was cheaper online but you get what you pays for, in terms of ease of return etc etc.

(edit)
misterhorsey
 
Posts: 413
Joined: Fri Apr 17, 2009 5:18 pm
Location: Northcote

Re: Radbot - 500 v 1000?

Postby macca33 » Thu Aug 08, 2013 5:13 pm

Still no problem with my Radbot 1000s (3 - on separate bikes) and average plenty of hours with them on burst mode - I'd say at least 30 hours (perhaps more and certainly over a month between changes) out of a set of batteries.

cheers
'dale CAAD10 Berzerker Ult6800 & CAAD10 Team Ult6800

Image
macca33
 
Posts: 825
Joined: Wed Sep 26, 2012 11:05 pm
Location: West Gippy

Re: Radbot - 500 v 1000?

Postby biker jk » Thu Aug 08, 2013 5:26 pm

misterhorsey wrote:My light still turns on, until the bike moves (or you simulate movement by shaking it), after which a contact point internally seems to skip a beat and then it goes dark.

On a side note, I bought this light online from cell. I rang their new fitzroy store to ask if I could drop by to discuss replacement/repair, and was advised that I could but it would be pointless as they are separate stores from online. I asked him if it was a franchise and he said that the name was franchised but not the store itself.

Rang cell who told me to send it back and they'll inspect and send me a new one. I asked if they would send me a different model, given the bad experience of the radbot, and they told me to write a note and they could discuss it (I'll pay the difference).

Hmmm. It was cheaper online but you get what you pays for, in terms of ease of return etc etc.

(edit)


Get the Cygolite Hotshot (Cell has it). It's excellent.
User avatar
biker jk
 
Posts: 2652
Joined: Tue Nov 17, 2009 5:18 pm
Location: Sydney

Re: Radbot - 500 v 1000?

Postby rdp_au » Thu Aug 08, 2013 6:07 pm

The problem is almost certainly the contacts between the two sides of the casing. These are disturbed every time you open the light to replace the batteries. Give both sets of contacts a good clean with contact cleaner or fine emery paper and maybe tweak them up a little if it looks like they've lost their spring ... As others have noted, they are not particularly waterproof and shouldn't be mounted where they get direct spray off the wheel. Mine is mounted above a mudguard and seems to be doing ok. Non the less, I've recently upgraded to a Hotshot as well - brighter and with convenience of a built in USB chargeable battery
User avatar
rdp_au
 
Posts: 507
Joined: Wed Feb 07, 2007 4:45 pm
Location: Hornsby, Sydney, NSW

Re: Radbot - 500 v 1000?

Postby Comedian » Fri Aug 09, 2013 6:36 am

rdp_au wrote:The problem is almost certainly the contacts between the two sides of the casing. These are disturbed every time you open the light to replace the batteries. Give both sets of contacts a good clean with contact cleaner or fine emery paper and maybe tweak them up a little if it looks like they've lost their spring ... As others have noted, they are not particularly waterproof and shouldn't be mounted where they get direct spray off the wheel. Mine is mounted above a mudguard and seems to be doing ok. Non the less, I've recently upgraded to a Hotshot as well - brighter and with convenience of a built in USB chargeable battery


I tried cleaning/tweaking the contacts etc. I agree this is the source of the problem. I did contemplate wiring from the batteries to the board, and putting in some nimh batteries. However the amount of stuffing around doesn't seem to warrant it. :)
Once you can climb hills on a bike it's all downhill. :mrgreen:

Hopefully I'll know what that's like..... one day. :shock: :lol:

Image
User avatar
Comedian
 
Posts: 4412
Joined: Mon Aug 09, 2010 7:35 pm
Location: Brisbane

Next

Return to Commuting

Who is online

Users browsing this forum: No registered users



Popular Bike Shops
Torpedo 7 Torpedo7 AU
Ground Effect Ground Effect NZ
Chain Reaction Cycles CRC UK
Wiggle Wiggle UK
Ebay Ebay AU

“Bicycles BNA Twitter
“Bicycles BNA Facebook
“Google+ BNA Google+
“Bicycles BNA Newsletter

> FREE BNA Stickers
> BNA Cycling Kit